[Instagram] When tapping an image or video, the image/video will not display properly (Firefox OS gets desktop content)

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: Petes, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-2] [country-all] [serversniff] [contactready], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8495596 [details]
im.txt

Description:
When tapping an image or video on instagram, the image/video will not display properly 

Setup Steps:
1) Flame device is set to 319mb

Repro Steps:
1) Update a Flame device to BuildID: 20140925000204
2) Go to 'therock instagram' on rocketbar
3) Tap the first link
4) Tap a image or video


Actual:
image/video is not center

Expected:
image/video display centered


Flame 2.1 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140925000204
Gaia: 8061ab487d42cbc49b329fd68b9ca90e0fe477e6
Gecko: e970bc96f8b5
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 80%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
This issue also reproduce on the Flame 2.2 KitKat Base (319mb), Flame 2.1 KitKat Base (512mb), and the Flame 2.0 KitKat Base (319mb). Image/video is not center


Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140925040206
Gaia: c5d2e2f4ebf5f370d6003517057dcd47493dec90
Gecko: 32acbe1d64dc
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.1 KitKat Base (512mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140925000204
Gaia: 8061ab487d42cbc49b329fd68b9ca90e0fe477e6
Gecko: e970bc96f8b5
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140924183011
Gaia: 87ee41fcb3f9a14d7a8bb67f1dd7fd95a6bcd0f0
Gecko: b1cb27078909
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(Reporter)

Comment 2

4 years ago
Created attachment 8496161 [details]
2014-09-25-15-55-30.png
The site sends desktop content to Firefox OS, and mobile content to other smartphones. Here's some analysis of the HTTP traffic. The different amounts of HTML data being sent - 173kB to Firefox OS and only 22kB to other smartphones - is evidence of server-side browser detection:

Significant difference in source code:
Smallest response has Content-Length: 22146
Largest response has Content-Length: 173649


Selected HTTP response headers (Firefox OS, Firefox on Android, Safari on iPhone):

Response for: 'Mozilla/5.0 (Mobile; rv:29.0) Gecko/29.0 Firefox/29.0'
Response Status: 200
content-length: 173649
content-type: text/html

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 200
content-length: 22146
content-type: text/html

Response for: 'Mozilla/5.0 (iPhone; CPU iPhone OS 6_0 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10A5376e Safari/8536.25'
Response Status: 200
content-length: 22865
content-type: text/html
Flags: needinfo?(dharris)
Whiteboard: [2.1-exploratory-2] → [2.1-exploratory-2] [country-all] [serversniff] [contactready]
Summary: [Instagram] When tapping an image or video, the image/video will not display properly → [Instagram] When tapping an image or video, the image/video will not display properly (Firefox OS gets desktop content)
Not nominating this to block, due to it being a tech evangelism issue
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]

Comment 5

2 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.