[Gallery] Flashing pixels when adjusting the exposure setting.

NEW
Unassigned

Status

Firefox OS
Gaia::Gallery
3 years ago
3 years ago

People

(Reporter: Johnt, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-exploratory-2])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8495610 [details]
logcat_20140925_1641.txt

Description:
When editing a photo from the gallery using the exposure setting there are flashing pixels from the adjustment bar below the button.


Repro Steps:
1) Update a Flame to 20140925000204
2) Have at least one photo in gallery.
3) Launce Gallery App.
4) Open a photo.
5) Select Edit.
6) Begin sliding the Exposure button slowly left and right.


Actual:
Lines from the exposure bar will begin flashing into the adjustable button.

Expected:
It is expected that the lines from the exposure bar will either appear on the exposure button, or not at all. 


Flame 2.1 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140925000204
Gaia: 8061ab487d42cbc49b329fd68b9ca90e0fe477e6
Gecko: e970bc96f8b5
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 100%
See attached: Logcat, Screenshot.
(Reporter)

Comment 1

3 years ago
Created attachment 8495612 [details]
FlashingPixels.png
(Reporter)

Comment 2

3 years ago
This issue does NOT occur on the 2.2 KitKat Base (319mb) and Flame 2.0 KitKat Base (319mb)

Description: Exposure button has no flashing pixels from the level bar.

Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140925040206
Gaia: c5d2e2f4ebf5f370d6003517057dcd47493dec90
Gecko: 32acbe1d64dc
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140924183011
Gaia: 87ee41fcb3f9a14d7a8bb67f1dd7fd95a6bcd0f0
Gecko: b1cb27078909
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(dharris)
Keywords: regression
Whiteboard: [2.1-exploratory-2]
The flashing pixel when moving the slider is really hard to notice so not nominating 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
(Reporter)

Comment 4

3 years ago
Created attachment 8498402 [details]
More Specific Image
You need to log in before you can comment on or make changes to this bug.