Intermittent browser_e10s_switchbrowser.js | Found an unexpected tab at the end of test run: dummy_page.html

RESOLVED FIXED in Firefox 35

Status

()

Core
DOM: Content Processes
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: KWierso, Assigned: mossop)

Tracking

(Blocks: 1 bug, {intermittent-failure})

unspecified
mozilla36
x86_64
Linux
intermittent-failure
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify -

Firefox Tracking Flags

(e10s+, firefox34 unaffected, firefox35 fixed, firefox36 fixed, firefox-esr31 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=48910917&tree=Fx-Team
Ubuntu VM 12.04 fx-team pgo test mochitest-e10s-browser-chrome-1 on 2014-09-25 16:32:29 PDT for push bcd0d2b817a8

slave: tst-linux32-spot-1060



16:35:24     INFO -  257 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_duplicateIDs.js
16:35:25     INFO -  258 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_duplicateIDs.js | took 587ms
16:35:25     INFO -  259 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js
16:35:25     INFO -  260 INFO 1
16:35:25     INFO -  261 INFO Loading http://example.org/browser/browser/base/content/test/general/dummy_page.html
16:35:25     INFO -  262 INFO Waiting for browser load
16:35:25     INFO -  263 INFO Saw state f0001 and status 0
16:35:25     INFO -  264 INFO Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.org/browser/browser/base/content/test/general/dummy_page.html" line: 0}]
16:35:25     INFO -  265 INFO Saw state c0010 and status 0
16:35:25     INFO -  266 INFO Browser loaded http://example.org/browser/browser/base/content/test/general/dummy_page.html
16:35:25     INFO -  267 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | Remote attribute should be correct
16:35:25     INFO -  268 INFO 2
16:35:25     INFO -  269 INFO Loading http://example.com/browser/browser/base/content/test/general/dummy_page.html
16:35:25     INFO -  270 INFO Waiting for browser load
16:35:26     INFO -  271 INFO Saw state f0001 and status 0
16:35:26     INFO -  272 INFO Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/browser/base/content/test/general/dummy_page.html" line: 0}]
16:35:26     INFO -  273 INFO Saw state c0010 and status 0
16:35:26     INFO -  274 INFO Browser loaded http://example.com/browser/browser/base/content/test/general/dummy_page.html
16:35:26     INFO -  275 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | Remote attribute should be correct
16:35:26     INFO -  276 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | Should have the right number of history entries
16:35:26     INFO -  277 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | Should have the right history index
16:35:26     INFO -  278 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | Should have the right URI
16:35:26     INFO -  279 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | Should have the right title
16:35:26     INFO -  280 INFO TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | Should have the right URI
16:35:26     INFO -  JavaScript error: , line 0: Error: operation not possible on dead CPOW
16:35:26     INFO -  JavaScript error: resource://gre/components/multiprocessShims.js, line 80: NS_ERROR_UNEXPECTED: Unexpected error
16:35:26     INFO -  281 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | Uncaught exception - [Exception... "Unexpected error"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/components/multiprocessShims.js :: AddonInterpositionService.prototype.getObjectTag :: line 80"  data: no]
16:35:26     INFO -  282 INFO Leaving test
16:35:26     INFO -  283 INFO Console message: [JavaScript Error: "NS_ERROR_UNEXPECTED: Unexpected error" {file: "resource://gre/components/multiprocessShims.js" line: 80}]
16:35:26     INFO -  284 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | took 1102ms
16:35:26     INFO -  285 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_e10s_switchbrowser.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/base/content/test/general/dummy_page.html - expected PASS
16:35:26     INFO -  286 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_fxa_oauth.js
16:35:27     INFO -  287 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_fxa_oauth.js | took 750ms
16:35:27     INFO -  288 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_getshortcutoruri.js
16:35:27     INFO -  289 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_getshortcutoruri.js | took 628ms
16:35:28     INFO -  290 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_hide_removing.js
16:35:28     INFO -  291 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_hide_removing.js | took 325ms
16:35:28     INFO -  292 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_homeDrop.js
16:35:28     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xA60001,name=PTexture::Msg___delete__) Route error: message sent to unknown actor ID
16:35:28     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xA60001,name=PTexture::Msg___delete__) Route error: message sent to unknown actor ID
16:35:29     INFO -  JavaScript error: resource://gre/components/contentAreaDropListener.js, line 91: NS_ERROR_DOM_BAD_URI: Access to restricted URI denied
16:35:29     INFO -  JavaScript error: resource://gre/components/contentAreaDropListener.js, line 91: NS_ERROR_DOM_BAD_URI: Access to restricted URI denied
16:35:29     INFO -  293 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_homeDrop.js | took 795ms
16:35:29     INFO -  294 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js
16:35:29     INFO -  295 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_lastAccessedTab.js | took 66ms
16:35:29     INFO -  296 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_overflowScroll.js
16:35:31     INFO -  297 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_overflowScroll.js | took 1983ms
16:35:31     INFO -  298 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_parsable_script.js
16:35:53     INFO -  299 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_parsable_script.js | took 21747ms
16:35:53     INFO -  300 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_pinnedTabs.js
16:35:53     INFO -  301 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_pinnedTabs.js | took 206ms
16:35:53     INFO -  302 INFO TEST-START | chrome://mochitests/content/browser/browser/base/content/test/general/browser_private_browsing_window.js
16:35:54     INFO -  JavaScript error: resource://gre/modules/LightweightThemeConsumer.jsm, line 91: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]
16:35:54     INFO -  JavaScript error: chrome://browser/content/urlbarBindings.xml, line 193: TypeError: this.formatValue is not a function
16:35:54     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xA60001,name=PTexture::Msg___delete__) Route error: message sent to unknown actor ID
16:35:54     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xA60001,name=PTexture::Msg___delete__) Route error: message sent to unknown actor ID
16:35:55     INFO -  303 INFO TEST-OK | chrome://mochitests/content/browser/browser/base/content/test/general/browser_private_browsing_window.js | took 1752ms
16:35:55     INFO -  must wait for focus
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Assignee: nobody → dtownsend+bugmail
Blocks: 984139
tracking-e10s: --- → +
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Blocks: 999239
Status: NEW → ASSIGNED
Iteration: --- → 35.3
Points: --- → 3
Flags: firefox-backlog+

Comment 7

3 years ago
Given that this is a testsuite failure, I'm assuming that the testsuite will be able to verify the fix and no manual QA work is needed for verification.
Flags: qe-verify-
Flags: in-testsuite+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 20

3 years ago
Created attachment 8504830 [details] [diff] [review]
Better reporting

The root problem here appears to be attempting to use a dead CPOW somewhere but I can't tell where because the error logged is pretty useless and it's too rare to reproduce locally. Right now it just logs the dead CPOW access and points blame into multiProcessShims.js. This patch catches failures to get an object tag and reports an error pointing to the code trying to access the cpow. I'm hoping that by landing this and waiting for this to reproduce again I can at least get some insight into where the faulty code is.
Attachment #8504830 - Flags: review?(wmccloskey)
(Assignee)

Updated

3 years ago
Keywords: leave-open
Attachment #8504830 - Flags: review?(wmccloskey) → review+

Updated

3 years ago
Iteration: 35.3 → 36.1
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/cb55300789e1
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 34

3 years ago
Created attachment 8510458 [details] [diff] [review]
patch

This test was using the shims to get at the session history. I'm still not sure why that is failing but we can avoid the shims entirely by using a frame script to grab the session history we need.
Attachment #8510458 - Flags: review?(felipc)
Attachment #8510458 - Flags: review?(felipc) → review+
(Assignee)

Comment 35

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/c667ca8f779a
(Assignee)

Updated

3 years ago
Keywords: leave-open
(Reporter)

Comment 36

3 years ago
https://hg.mozilla.org/mozilla-central/rev/c667ca8f779a
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
status-firefox34: --- → unaffected
status-firefox35: --- → affected
status-firefox36: --- → fixed
status-firefox-esr31: --- → unaffected
https://hg.mozilla.org/releases/mozilla-aurora/rev/da97b18e9e43
status-firefox35: affected → fixed
You need to log in before you can comment on or make changes to this bug.