[Browser]Share button is disabled if the activity(Email) is not closed

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
4 years ago
7 months ago

People

(Reporter: vsireesha246, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [LibGLA,TD101767,QE2, B])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
STR:

Browser - youtube - Share - E-mail - Attach - Music - Random music select - Play - Home key press - open Browser

Actual:Share button is disabled

Expected:Share button should be active
(Reporter)

Updated

4 years ago
Whiteboard: [LibGLA,TD101767,QE2, B]
(Reporter)

Comment 1

4 years ago
In V2.0 this is due to handleShareButtonClick() implementation

We are enabling the 'Share' button activity.onsuccess and activity.onerror case.
If the activity is in background we will not get these functions,so the 'Share' is in disabled state.

Is there any specific reason to do this.Actually we are restricting the use by disabling the 'Share'.

Asking need info to Yliao on this.
Flags: needinfo?(yliao)
(Reporter)

Comment 2

4 years ago
As per IRC chat with Ben the share is disabled due to this bug https://bugzilla.mozilla.org/show_bug.cgi?id=1011611

Need to check for a workaround 'onvisibilitychange' event we can re-enable the 'Share' button.

Thanks..
Sireesha
(Reporter)

Comment 3

4 years ago
Created attachment 8496687 [details] [diff] [review]
V2.0 Bug_1073398.patch

Hi Ben,

Would you please review the attached patch and let me know your review comments.
If you are fine with this patch i will create PR for the same.

Thanks..
Sireesha
Attachment #8496687 - Flags: review?(bfrancis)
Flags: needinfo?(yliao)
Comment on attachment 8496687 [details] [diff] [review]
V2.0 Bug_1073398.patch

Review of attachment 8496687 [details] [diff] [review]:
-----------------------------------------------------------------

This looks OK to me, thanks.

Is this a 2.1 blocker? Just a reminder that the browser app is about to be deleted in master in bug 1043959.
Attachment #8496687 - Flags: review?(bfrancis) → review+

Comment 5

7 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.