clicking noise even with lockscreen or screen powered off, fixable by deactivating Wi-Fi or enabling camera

RESOLVED DUPLICATE of bug 1089434

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1089434
3 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Boot2Gecko 2.1.0.0-prerelease 20140925000204 on Flame running Kitkat

Noticed this twice today: The phone was emitting a clicking noise with a frequency of a few hundred clicks/minute, audible in a distance of 30 centimeter or less, even when the screen was powered off. Enabling the camera stopped the noise the first time I noticed it (maybe it's the camera shutter?), the second time it went away after I disabled the Wi-Fi. I have no steps to reproduce for making the clicking start.

Comment 1

3 years ago
Same here, using base image v180 on Flame. Gaia-version makes no difference.

Mine clicks whenever Wi-Fi is active, starting in FTU when WLAN-key is entered. Clicking stops while Wi-Fi is deactivated or camera is active.

Watching logcat during boot, it starts clicking here:

D/wpa_supplicant(  984): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 50 4f 4c 4c
D/wpa_supplicant(  984): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant(  984): nl80211: survey data missing!
I/cat     (  228): <7>[   31.629888] DOM Worker: unhandled page fault (11) at 0xb0240c50, code 0x00f
I/cat     (  228): <1>[   31.629909] pgd = ec428000

After physically removing the camera module the clicking is gone.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089434
You need to log in before you can comment on or make changes to this bug.