Closed Bug 1073437 Opened 6 years ago Closed 6 years ago

Click noises when using web audio API

Categories

(Core :: Web Audio, defect)

32 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 848954

People

(Reporter: johannes.kissel, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20140923222114

Steps to reproduce:

I connected an oscillator to the audio context destination and started it for 10s.


Actual results:

There are clicking noises during playback at random time.

It seems you can increase the noises when adding effects, e.g. a gain node with a linear ramp:
http://jsfiddle.net/kfd4umtp/

This does not happen e.g. in Chrome. I'm using a 2013 MacBook Air, but also tried on a Windows 7 Toshiba.


Expected results:

There should not be any clicking noises during playback.
confirming with Firefox32 and windows7
Status: UNCONFIRMED → NEW
Component: Untriaged → Web Audio
Ever confirmed: true
Product: Firefox → Core
This should be fixed in version 34.
It is in my testing, but please reopen if you find otherwise.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 848954
You need to log in before you can comment on or make changes to this bug.