Email msg text erroneously deleted by single keystroke

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: tcharlesyun, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps:

1.  Open a new email message window (Ctrl-M)
2.  Use "tab" to move from address to subject to the body of the email.
3.  Type in a long string of text so that it word wraps.
4.  Stay at the end of the text and press the delete key several times
5.  You will find that the entire previous paragraph is deleted
6.  the UNDO funtion will not return the text

Some additional notes:
- I have set up mail to NOT use HTML mail.  I believe that there are several
other issues related to this (such as odd line behaviors after a hard break). 
(From the screen artifacts, it seems that the ASCII-text mail is actually hiding
some information that is being ignored?)
- I have a plain ascii sig file that does not seem to change the odd behavior.
- This bug will re-occur repeatedly... almost.  If you "select all text" and
delete all the text on the screen, the steps above will not cause the error.  It
seems that there needs to be at least one line of text after the paragraph for
the bug to occur.
(Reporter)

Updated

17 years ago
Summary: Msg text erroneously deleted by single keystroke → Email msg text erroneously deleted by single keystroke

Comment 1

17 years ago
Reporter: Please remember to always include the build ID in bug reports.
Possible duplicate of bug 101690 (fix was checked in on the 19th.)

Updated

17 years ago
QA Contact: sheelar → esther

Comment 2

17 years ago
Reporter (T. Charles Yun) can you please confirm that this still occurs in a
recent mozilla builds (0.9.9 or better yet a nightly build)?
(Reporter)

Comment 3

17 years ago
I am currently running build 2002031104 and the problem has been fixed.  Thanks,
great job and I look forward to 1.0!



Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

16 years ago
Verified as fixed and dup of 101690
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.