Closed Bug 1073537 Opened 5 years ago Closed 5 years ago

Skip payload.info.revision check on non-official builds

Categories

(Toolkit :: Telemetry, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: gfritzsche, Assigned: gfritzsche)

References

Details

Attachments

(1 file)

This check here fails (expectedly) on non-official builds (i.e. MOZILLA_OFFICIAL not set):
http://hg.mozilla.org/mozilla-central/annotate/5e704397529b/toolkit/components/telemetry/tests/unit/test_TelemetryPing.js#l159

When bug 1073536 allows us to check |MOZILLA_OFFICIAL| from inside the test, we could just skip this part and be pain-free for local testing.
Duplicate of this bug: 1079201
Assignee: nobody → georg.fritzsche
Status: NEW → ASSIGNED
Attachment #8501034 - Flags: review?(nfroyd)
Comment on attachment 8501034 [details] [diff] [review]
Dont check revision specifics on unofficial builds

Review of attachment 8501034 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #8501034 - Flags: review?(nfroyd) → review+
https://hg.mozilla.org/mozilla-central/rev/e4368578fe83
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.