Crash on startup when clicking mail link [@ nsXULDocument::OnStreamComplete ]

RESOLVED WORKSFORME

Status

()

Core
Networking
--
critical
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Ashley Bischoff (blog at handcoding.com), Assigned: Darin Fisher)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011029
BuildID:    2001102903

Mozilla wasn't started yet. But, I clicked on a link in my non-Mozila mail
client. Mozilla tried to start, but crashed. I don't think the splash screen
even appeared. 

Talkback ID: TB37345938X

Reproducible: Didn't try
Steps to Reproduce:
1. Make sure Mozilla isn't running
2. Click on a link in a non-Mozilla mail client 
3. Crash

(I'm not certain about the steps, but that's the sequence that crashed for me)

Actual Results:  Crash

Expected Results:  No crash
CC: stephend@netscape.com, for talkback retrieval, please (TB37345938X)
Keywords: crash

Comment 2

17 years ago
probably dup of bug 107334
R.K.Aa: Sure, it may be possible this bug 107334 and this bug have the same root
cause. But, their descriptions are quite different -- bug 107334 describes a
crash in MailNews, whereas this crash describes a Browser crash from loading a
Windows Integration link.

One more thing to add to the bug description: I see no crash when loading a
Windows Integration link if the Browser is already running -- this only occurs
if Mozilla isn't running.

Comment 4

17 years ago
sorry - i assumed it was a mailto link & Moz mailnews set as default mailer.
This can be anything.
Incident ID 37352572
Stack Signature nsAString::do_AssignFromReadable 7c7ddf7e
Bug ID
Trigger Time 2001-10-29 10:02:04
Email Address thorsten.konetzko@gmx.net
URL visited http://dhtmlkitchen.com/dhtml/replaceEl/replaceEl.html
User Comments see #107367
Build ID 2001102811
Product ID MozillaTrunk
Platform ID Win32
Trigger Reason Access violation
Stack Trace
nsAString::do_AssignFromReadable
[d:\builds\seamonkey\mozilla\string\src\nsAString.cpp, line 290]
nsAString::AssignFromReadable
[d:\builds\seamonkey\mozilla\string\src\nsAString.cpp, line 741]
nsFont::operator= [d:\builds\seamonkey\mozilla\gfx\src\nsFont.cpp, line 104]
nsFontMetricsWin::Init
[d:\builds\seamonkey\mozilla\gfx\src\windows\nsFontMetricsWin.cpp, line 448]
nsFontCache::GetMetricsFor
[d:\builds\seamonkey\mozilla\gfx\src\nsDeviceContext.cpp, line 565]
DeviceContextImpl::GetMetricsFor
[d:\builds\seamonkey\mozilla\gfx\src\nsDeviceContext.cpp, line 229]
ComputeLineHeight
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowState.cpp, line 2202]
nsHTMLReflowState::CalcLineHeight
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowState.cpp, line 2244]
nsBlockReflowState::nsBlockReflowState
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowState.cpp, line 175]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 718]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 737]
nsHTMLButtonControlFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsHTMLButtonControlFrame.cpp,
line 676]
nsLineLayout::ReflowFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 1038]
nsBlockFrame::ReflowInlineFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3659]
nsBlockFrame::DoReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3540]
nsBlockFrame::DoReflowInlineFramesAuto
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3465]
nsBlockFrame::ReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3410]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2479]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2142]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 827]
nsBlockReflowContext::DoReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
581]
nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
359]
nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3153]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2364]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2142]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 827]
nsAbsoluteContainingBlock::ReflowAbsoluteFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsAbsoluteContainingBlock.cpp,
line 445]
nsAbsoluteContainingBlock::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsAbsoluteContainingBlock.cpp,
line 230]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 997]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 660]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 737]
CanvasFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp, line 570]
nsBoxToBlockAdaptor::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 891]
nsBoxToBlockAdaptor::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 540]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 1002]
nsScrollBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsScrollBoxFrame.cpp, line 392]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 1002]
nsContainerBox::LayoutChildAt
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 653]
nsGfxScrollFrameInner::LayoutBox
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 1026]
nsGfxScrollFrameInner::Layout
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 1137]
nsGfxScrollFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 1034]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 1002]
nsBoxFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 944]
nsGfxScrollFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 752]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 737]
ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 575]
nsHTMLReflowCommand::Dispatch
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowCommand.cpp, line 217]
PresShell::ProcessReflowCommand
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5996]
PresShell::ProcessReflowCommands
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6051]
ReflowEvent::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5907]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 303]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1315]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1632]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1650]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e87d08) 

*** This bug has been marked as a duplicate of 106341 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Matti: Is that dupe based on the stack info? I only ask because, while
reporter's talkback was TB37345938X, the talkback retrieved was 37352572 :-/.

Stephen: Could you retrieve TB37345938X, please?

-> Reopening, for now
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Yes, i duped it because the stacks are identical but didn't saw that this is a 
stack from a wrong TB ID
Incident ID 37345938
Stack Signature nsXULDocument::OnStreamComplete 1131be5e
Bug ID
Trigger Time 2001-10-29 07:49:44
Email Address alex@spamcop.net
URL visited
User Comments Crash on startup -- I clicked on a link in my mail client.
Build ID 2001102906
Product ID MozillaTrunk
Platform ID Win32
Trigger Reason Access violation
Stack Trace
nsXULDocument::OnStreamComplete
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 6028]
nsStreamLoader::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamLoader.cpp, line 139]
nsJARChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp, line 614]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 177]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 303]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1315]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1632]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1650]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
Matti: The stack signature is nsXULDocument::OnStreamComplete, but I'm not sure
which component that goes with. Any ideas?

Stephen: Thanks for your help!
Summary: Crash on startup when clicking mail link (TB37345938X) → Crash on startup when clicking mail link [@ nsXULDocument::OnStreamComplete ]
sounds like -> Networking
Assignee: asa → neeti
Status: REOPENED → NEW
Component: Browser-General → Networking
QA Contact: doronr → benc

Comment 12

17 years ago
Darin: Is this a networking bug?
Assignee: neeti → darin
(Assignee)

Comment 13

17 years ago
this might be a networking bug... it's hard to tell.  there appears to be a
crash in the XUL document loader code, but that crash point is not to far
removed from the networking code.  we'll have to investigate this some to see
what might be going on.  networking could be holding onto a junk pointer, or
something like that.

Comment 14

17 years ago
I tested this bug on windows NT4, but could not reproduce it. Following are the
builds on which I have tested.
a) buildID - 2001101117 - 0.9.5
b) buildID - 2001112009 - 0.9.6
c) Netscape 6.2  - 0.9.4.1
d) latest cvs code pulled on Nov 23 2001.
Steps carried to reproduce the bug were as follows:
a) Used microsoft outlook as the mail client.
b) Opened a mail having a link in outlook, and clicked on the link.
 The browser opens the respective url, I do not experience crash of the browser.
During testing I made sure that mozilla is not running, and had set mozilla as
my default browser.

If anyone has any more details to reproduce the bug, please convey, and is it
specific only to Windows2000.

Comment 15

17 years ago
I tested this bug on windows NT4, but could not reproduce it. Following are the
builds on which I have tested.
a) buildID - 2001101117 - 0.9.5
b) buildID - 2001112009 - 0.9.6
c) Netscape 6.2  - 0.9.4.1
d) latest cvs code pulled on Nov 23 2001.
Steps carried to reproduce the bug were as follows:
a) Used microsoft outlook as the mail client.
b) Opened a mail having a link in outlook, and clicked on the link.
 The browser opens the respective url, I do not experience crash of the browser.
During testing I made sure that mozilla is not running, and had set mozilla as
my default browser.

If anyone has any more details to reproduce the bug, please convey, and is it
specific only to Windows2000.
(Assignee)

Comment 16

17 years ago
marking WORKSFORME per nivedita's findings.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsXULDocument::OnStreamComplete ]
You need to log in before you can comment on or make changes to this bug.