Closed Bug 1073637 Opened 8 years ago Closed 4 years ago

[Apple] When playing a video, the user will get a message that the file is corrupt

Categories

(Web Compatibility :: Mobile, defect, P5)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: psiphantong, Unassigned)

References

()

Details

(Whiteboard: [2.1-exploratory-2] [country-all] [notcontactready] [video])

Attachments

(2 files)

Attached file av.txt
Description:
When playing a video on Apple, the user will get a message that the file is corrupt 

Setup Steps:
1) Flame device is set to 319mb

Repro Steps:
1) Update a Flame device to BuildID: 20140926000202
2) Go to Apple
3) Tap 'watch the film' 
4) Tap the first video


Actual:
video file is does not play/corrupt

Expected:
video plays


Flame 2.1 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140926000202
Gaia: 6a6ed9433fce47e76c07fd35bc5952acb108f4c8
Gecko: 7b09a378588c
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
See attached: screenshot, logcat
Attached image 2014-09-26-13-37-39.png
This issue also reproduce on the Flame 2.2 KitKat Base (319mb), Flame 2.1 KitKat Base (512mb), and the Flame 2.0 KitKat Base (319mb). Video file does not play/corrupt


Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140926040203
Gaia: a06714c555ca7068545f10b4437a16c14cd8e7f5
Gecko: 9e3d649b80a2
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.1 KitKat Base (512mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140926000202
Gaia: 6a6ed9433fce47e76c07fd35bc5952acb108f4c8
Gecko: 7b09a378588c
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0 KitKat Base (319mb)

Device: Flame 2.0
BuildID: 20140926063008
Gaia: c1aa7829548e65360472c31544dbe2839eaf5be1
Gecko: 5a9f1f402425
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
The site just links to .mov files like this one

http://images.apple.com/media/us/iphone-6/2014/cb62df28-5fd5-4ca9-a9be-78f836f209b0/tv-spots/huge/iphone6-huge-cc-us-20140922_r848-9dwc.mov

which on desktop launch in QuickTime (through some JS creating an EMBED element in the page). On an Android HTC all browsers try to launch it with the Streaming Media Player, but this fails just like on the Flame. Seems Apple don't worry about platforms that don't run QuickTime?
Not a blocker and these videos do not work on Android either as stated in Comment 3.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Whiteboard: [2.1-exploratory-2] → [2.1-exploratory-2] [country-all] [notcontactready] [video]
Priority: -- → P5
The Firefox OS project is not active anymore.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.