[Contacts] Scrolling the contacts alphabet popup will display a white box behind the quick search indicator

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: jschmitt, Assigned: arcturus, Mentored)

Tracking

({regression})

unspecified
2.1 S6 (10oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-exploratory-2])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8496234 [details]
log.txt

Description:
A white box appears behind the quick search.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140926000202
2) Open Contacts app
3) Make a new contact
4) Open the Contact apps Settings
5) Select 'Import Contacts'
6) Pess 'Done'
7) Scroll on the Alphabet or 'quick search'
  
Actual:
A white box appears when scrolling.
  
Expected: 
A white box does not appear when scrolling.
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20140926000202
Gaia: 6a6ed9433fce47e76c07fd35bc5952acb108f4c8
Gecko: 7b09a378588c
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes:
Repro frequency: 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8496241 [details]
Alphabet.png

Issue does NOT occur on 2.2 and 2.0 Flame 319MB KK.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140926040203
Gaia: a06714c555ca7068545f10b4437a16c14cd8e7f5
Gecko: 9e3d649b80a2
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Environmental Variables:
Device: Flame 2.0
BuildID: 20140926063008
Gaia: c1aa7829548e65360472c31544dbe2839eaf5be1
Gecko: 5a9f1f402425
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(ktucker)
Whiteboard: [2.1-exploratory-2]
Mentor: francisco
Whiteboard: [2.1-exploratory-2] → [2.1-exploratory-2] [good first bug]
[Blocking Requested - why for this release]: Regression from 2.0
blocking-b2g: --- → 2.1?
Keywords: regression
Target Milestone: --- → 2.1 S6 (10oct)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Hi Sergi, once solved, can you ask for approval to uplift to 2.1?
Flags: needinfo?(sergi.mansilla)
triage: identifiable regression
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(francisco)
Woops, wrong bug, no Sergi ni needed here.
Flags: needinfo?(sergi.mansilla)
This is a 2.1 blocker, probably not a good first bug.
Whiteboard: [2.1-exploratory-2] [good first bug] → [2.1-exploratory-2]
QA Whiteboard: [QAnalyst-Triage+]
Keywords: regressionwindow-wanted
QA Contact: ckreinbring
Will assing to myself and let's see how we can fix this.
Assignee: nobody → francisco
Flags: needinfo?(francisco)
Hi,

I've been trying for a while, with base image v180 and latest v2.1 and cannot reproduce it.
Don't see any white background around the component.
Asked Johan if he can reprod.
I'm not able to reproduce either on:
Gaia-Rev        9861c61ec302fb0316c753a2e1c0f592180515fd
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/da68900d1c66
Build-ID        20141003000203
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.jlorenzo.20141002.104456
FW-Date         Thu Oct  2 10:45:09 CEST 2014
Bootloader      L1TC10011800

Josh, can you check again on today's build? If you're able to repro, would you mind attaching a video?
Flags: needinfo?(jschmitt)
This issue no longer occurs on the latest builds whether shallow flashed or full flashed.

Environmental Variables:
Device: Flame 2.2
BuildID: 20141003070740
Gaia: a8a6eed2ba9d66239aac789b9ee4900f911c73cb
Gecko: 388e101e75c8
Version: 35.0a1 (2.2) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Environmental Variables:
Device: Flame 2.1
BuildID: 20141003105147
Gaia: b63757fec42b9be7e35aa028c7646177594db7b8
Gecko: 9c34e69ff5b0
Version: 34.0a2 (2.1) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Issue no longer repro's - closing as WFM
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jschmitt)
Flags: needinfo?(jmitchell)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.