incorrect history when using search button

VERIFIED WORKSFORME

Status

--
minor
VERIFIED WORKSFORME
17 years ago
11 years ago

People

(Reporter: gaborliptak, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011027
BuildID:    2001102708

incorrect history when using search button

Reproducible: Always
Steps to Reproduce:
1. load any page
2. type some search terms into the URL field
3. click the search button
4. click the backward arrow
5. notice there is no forward arrow (although the search result page is to be
the next page)

Actual Results:  forward arrow disabled

Expected Results:  the search result page is to be the next page
to search [or, history?]
Assignee: pchen → sgehani
Component: XP Apps → Search
QA Contact: sairuh → claudius

Comment 2

17 years ago
Can't reproduce with neither 2001101909 nor 2001102903 on Win2K.

(Reporter)

Comment 3

17 years ago
I do not have "Hide the tab bar when only one tab is open" checked. Maybe that 
is what different?
(Assignee)

Comment 4

17 years ago
Reporter,
Have you tried this with a new profile?  Does this occur for you when you use
history without involving the search button, i.e., 
(a) open a page, 
(b) click a link, 
(c) try to go back and 
(d) then forward again?  

I can't reproduce this with a 2001102903 build on Win2K either.  Marking
worksforme.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
Under Win 98SE
Mozilla 0.9.5 (2001101117)
it is working fine, after the forward button click is going back into the google
search with the results of query i've searched for.
(Reporter)

Comment 6

17 years ago
regular backward/forward seems to be working.

I have tried this with a new profile. By default it did search against Netscape 
and opened the "Sidebar" (which I closed before ...), and exhibited the 
behaviour as described in the bugreport.

Did you try it with a new profile?
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.