If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

APK download fails with 504

RESOLVED WONTFIX

Status

Marketplace
Integration
P3
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: tuxor, Unassigned)

Tracking

2014-Q3
All
Android
Points:
---

Details

(Whiteboard: [marketplace-transition])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140918134209

Steps to reproduce:

1. Open Loqui IM page on marketplace with Firefox for Android: https://marketplace.firefox.com/app/loqui
2. Click on install and wait


Actual results:

End up getting "504 Gateway Timeout"


Expected results:

Apk should be generated, downloaded and an install prompt should show up.
(Reporter)

Updated

3 years ago
OS: All → Android
(Reporter)

Comment 1

3 years ago
Alternatively, directly try:

curl -v 'https://controller.apk.firefox.com/applicion.apk?manifestUrl=http://marketplace.firefox.com/app/7b41976f-cb97-4b90-a711-a71376d21d42/manifest.webapp'
I can reproduce this but it may only be happening for specific manifests. I got a 200 response from this:

curl -v 'https://controller.apk.firefox.com/application.apk?manifestUrl=https://marketplace-dev.allizom.org/app/f34d3c22-3efe-47ca-803d-6c740da1a851/manifest.webapp'

and I'm pretty sure this was not cached because my first hit to it paused as if building.

Jason, my link to the APK's server logs on kibana is broken. Where are they now? Or do you see something obvious in there?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jthomas)
(Reporter)

Comment 3

3 years ago
By the way, there was a typo in Comment #1 (applicion instead of application). But don't worry: this did not actually cause the 504 in the first place, the typo was not there when I did the testing ;-)

However, now installing apps from marktplace works fine - no 504's. Would be still good to have a look into the logs to determine what might have caused this issue - I was seeing it since 24 hours from now (i.e. several hours before I filed this bug report).
Prod APK logs are listed here https://mana.mozilla.org/wiki/pages/viewpage.action?pageId=38547561#controller.apk.firefox.com&generator.apk.firefox.com%28APKFactoryService%29-Kibana/Logging

I don't see anything specific in the application logs, but I do see a handful of 504s in the nginx logs. The generator instances look okay but I restarted them anyways.
Flags: needinfo?(jthomas)

Updated

3 years ago
Blocks: 1060446
Priority: -- → P2

Updated

3 years ago
Priority: P2 → P3

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Whiteboard: [marketplace-transition]
You need to log in before you can comment on or make changes to this bug.