Provide a way to stop flash video when there are no video controls

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: john ruskin, Unassigned)

Tracking

32 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Opened a URL in a tab
     http://www.cnbc.com/id/102035634

On that page there is a flash object, and unlike other video on the web, this one has no video controls.

The object reports the player as
     thePlatform PDK
with a version:
     5.5.3.359507 (2014-08-28 10:04 am)

I am using updated flash:
     15.0.0.152

The bug is similar to those that auto-play issues on various sites, reported in other bugs.   Only this is different in that there is no manual means to stop the video.

One fix is forcing a means to allow FireFox to -stop- a video, despite the player's code/configuration.  This distinguishes from the other autoplay bugs which seek for prevent autoplay in the first place, ie, to only -start- with an affirmative user action.

Because of the possibility that there are different things going on, initiating and playing the video on this particular page, or that I seek to stop a flash video despite the Flash player's coding, or because there might be additional/different considerations for the fix in this case,  I have opened a separate bug.
1) I see a pause button on that player
2) In the location bar, click the plugin icon, click "Block Plugin".

I'm not sure we can do much else.
Component: Untriaged → General
Summary: "The Platform PDK" flash video starts up, and has no stop controls → Provide a way to stop flash video when there are no video controls
(Reporter)

Comment 2

4 years ago
Thanks for responding, Gjis; your view perplexed me

Before filing the bug, I had disabled Ghostery and Adblock, on the assumption that they would change behavior (disabling those two, in the past, has resolved all sorts of page display problems).   Disabling them did not change my view, and so I filed the bug.

After your comment, just now, I restarted in safe mode, and, indeed, the controls showed up.   I'm not sure which of the add-ons remaining could have mangled the display, but I'll try to find out.

In the meantime, I am marking this bug as resolved/invalid 

Thanks, again.   Lesson learned....!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

4 years ago
Turns out that it was HTTPS-Everywhere.   Disabling the rule "CNBC - partial" allows the control bar to show up, even with AdBlock and Ghostery enabled.
You need to log in before you can comment on or make changes to this bug.