Audio sound pitch is wrong

VERIFIED FIXED in Firefox 34

Status

()

Core
Audio/Video
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Alice0775 White, Assigned: cpearce)

Tracking

({regression})

34 Branch
mozilla35
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox32 unaffected, firefox33 unaffected, firefox34+ verified, firefox35+ verified)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
[Tracking Requested - why for this release]: regression

Steps To Reproduce:
1. Open http://www.kulturradio.de/_testfolder_fuer_alle/5-1.html
2. Play back Teaser

Actual Results:
Women voice pitch is too low

Actual Results:
Women voice pitch should be normal. IE11 and Chrome work properly
(Reporter)

Comment 1

4 years ago
Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b91deae84856
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140825183854
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/efe5844c9a5b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140825193622
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b91deae84856&tochange=efe5844c9a5b

Regressed by:
efe5844c9a5b	Chris Pearce — Bug 1057879 - Enable MP4Reader on Windows. r=kentuckyfriedtakahe
Blocks: 1057879
I've got to admit that I'm unless the issue is with the volume of the woman's voice, I'm not sure what the difference is between the browsers. Chris, Anthony - Alice has wonderfully provided a regression window. Can you please review the problem description and see if you can reproduce the issue?
status-firefox32: --- → unaffected
tracking-firefox34: ? → +
tracking-firefox35: ? → +
Flags: needinfo?(cpearce)
Flags: needinfo?(ajones)

Comment 3

4 years ago
(In reply to Lawrence Mandel [:lmandel] from comment #2)
> I've got to admit that I'm unless the issue is with the volume of the
> woman's voice, I'm not sure what the difference is between the browsers.
> Chris, Anthony - Alice has wonderfully provided a regression window. Can you
> please review the problem description and see if you can reproduce the issue?

Basically, it's a speed issue.  It's playing back really really slow -- she sounds like a man with a serious speech impediment.
(Assignee)

Comment 4

4 years ago
I can reproduce this bug. We can revert https://hg.mozilla.org/mozilla-central/rev/efe5844c9a5b if we don't get round to fixing this by the time it hits beta.
Flags: needinfo?(cpearce)
(Assignee)

Comment 5

4 years ago
Created attachment 8497118 [details] [diff] [review]
Patch

Pretty easy fix; the WMF MFT doesn't send us a MF_E_TRANSFORM_STREAM_CHANGE for this file when the first output sample has a different stream type than we asked for. So just re-evaluate the output type whenever there's a discontinuity. This will happen on the first sample output, and when we seek.
Assignee: nobody → cpearce
Status: NEW → ASSIGNED
Attachment #8497118 - Flags: review?(kinetik)
Flags: needinfo?(ajones)
Attachment #8497118 - Flags: review?(kinetik) → review+
(Assignee)

Comment 6

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/0f3397b2fff3

We'll want this uplifted to aurora.
(Assignee)

Updated

4 years ago
Flags: needinfo?(cpearce)
https://hg.mozilla.org/mozilla-central/rev/0f3397b2fff3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox35: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
(Assignee)

Comment 8

4 years ago
Comment on attachment 8497118 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1055383, new MP4 playback backend on Windows
[User impact if declined]: Some video files will not play audio
[Describe test coverage new/current, TBPL]: Did not regress existing mochitests..
[Risks and why]: Low risk.
[String/UUID change made/needed]: None.
Attachment #8497118 - Flags: approval-mozilla-aurora?
Flags: needinfo?(cpearce)
Comment on attachment 8497118 [details] [diff] [review]
Patch

Aurora+
Attachment #8497118 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 10

4 years ago
Aurora checkin needed.
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/c19814f20996
status-firefox34: affected → fixed
Keywords: checkin-needed
QA Whiteboard: [good first verify]

Comment 12

4 years ago
testday-20141107 VERIFIED FIXED
(In reply to Alona from comment #12)
> testday-20141107 VERIFIED FIXED

Alona, on what version was this verified? Was it 34 or 35?
Flags: needinfo?(alenakunik)

Comment 14

4 years ago
version 34.0. I followed the instructions of Testday.
Flags: needinfo?(alenakunik)
QA Whiteboard: [good first verify] → [good first verify][testday-20141107]
status-firefox34: fixed → verified
Depends on: 1096716
Status: RESOLVED → VERIFIED
status-firefox35: fixed → verified
Target Milestone: mozilla35 → mozilla34
You need to log in before you can comment on or make changes to this bug.