If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sound Front-Right and Front-Center are interchanged

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

29 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox32 affected, firefox33 affected, firefox34 affected, firefox35 affected, firefox45 affected, firefox46 wontfix, firefox47 wontfix, firefox48 fixed, firefox-esr31 affected, firefox-esr38 affected, firefox-esr45 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8496405 [details]
HTML5_51.m4a

Steps to Reproduce:
1. Open attached

Actual Results:
Sound Front-Right and Front-Center are interchanged

Expected Results:
As Windows Media Player, IE11 and Chrome37
(Reporter)

Comment 1

3 years ago
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/327a6af06942
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20131216054553
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3f48392a6250
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20131216060353
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=327a6af06942&tochange=3f48392a6250

Suspect:
	41fc2afc8465	Alexandros Chronopoulos — Bug 911482 - Perform audio downmix inside AudioStream class. r=rillian
Blocks: 911482
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1168122
Component: Audio/Video → Audio/Video: Playback
(Reporter)

Comment 3

2 years ago
Bug 1248861 also fixed this problem on Latest m-i build[1].

[1]
https://hg.mozilla.org/integration/mozilla-inbound/rev/be02aaa8b2e8099047ac3c9dcb8ee06810cda5ee
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0 ID:20160408004242
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox47: --- → affected
status-firefox48: --- → fixed
status-firefox-esr38: --- → affected
status-firefox-esr45: --- → affected
Resolution: --- → WORKSFORME
status-firefox46: affected → wontfix
status-firefox47: affected → wontfix
You need to log in before you can comment on or make changes to this bug.