Lightning/Sunbird stops working during CalDav Sync

RESOLVED DUPLICATE of bug 875739

Status

RESOLVED DUPLICATE of bug 875739
4 years ago
4 years ago

People

(Reporter: holgstiller, Unassigned)

Tracking

Lightning 2.6.6

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8496406 [details]
Sunbird-Bug.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

I have a owncloud server and use Lightning as Calender client. The issue also appears on Sunbird.
I synchronize my calendar via CalDav with owncloud.
I created a new appointment with Lightning and stored it on owncloud. Since then Lightning was not able to synchronize the calendar at all and stopped working (only solutio to kill task).
I used :
Thunderbird 24.6.0
Lightning : 2.6.6
Owncloud : 7.02



Actual results:

Lightning and Sunbird stopped working.
I have identified the data set in owncloud calendar that causes the problem.
When I load the attached data set to the owncloud database the respective calendar will not be able to be synchronized anymore.
Synchronization with Android or the owncloud web-interface still works fine.


Expected results:

I would have expeted that Lightning just syncrhonized the appointment.
Hi, Sunbird development was stopped in 2010. Don't expect any updates. Your Lightning version indicates that you are using old Thunderbird version. Consider updating to current releases like Thunderbird 31 with Lightning 3.3 to benefit from bug fixes and other improvements.

In your sample I see two CN parameters indicating that this is the same problem as in Bug 875739:
> ATTENDEE;PARTSTAT=NEEDS-ACTION;CN= Firstname;CN=Lastname\\;RSVP=TRUE;ROLE=REQ-PA
>  RTICIPANT:mailto:name.lastname@my.other.domain.com

The section |CN= Firstname;CN=Lastname\\;| looks kind of odd too, with the space in front and the double backslash at the end. Maybe there used to be quotes like "Firstname Lastname" and either Lightning or ownCloud or one of the other tools you use failed to parse this correctly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875739
You need to log in before you can comment on or make changes to this bug.