The incoming datastream is html page itself when npp_newstream() get called

VERIFIED DUPLICATE of bug 91238

Status

()

VERIFIED DUPLICATE of bug 91238
17 years ago
16 years ago

People

(Reporter: shao, Assigned: serhunt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
let me suppose a server always response the plug-in with a MIME 
type "application/x-test" stream. When npp_newstream() get called at first time 
in NS4.7, the incoming stream is "application/x-test", however, in NS6.1, this 
will be "text/html", and the content will be the html page which "<EMBED>"s the 
plugin. This problem can easily be skipped by testing the MIME type for the 
first time and send same request again, but it does cause a little imcompatible 
problem with NS4.7. I am wondering if this is a new rule change, or a bug
(Assignee)

Comment 1

17 years ago
It is hard to say now whether it was supposed to be a feature or was just a bug. 
Anyway: bug 91238 -- it was fixed quite a time ago.

*** This bug has been marked as a duplicate of 91238 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.