Mouse handling regression in main acid test.

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: mbx, Assigned: till)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Hovering the mouse over the nose no longer causes it to spin.
Looks like this regressed in https://github.com/mozilla/shumway/pull/1711. The rotated rectangle in the center (further referred as "the nose") is fully covered by an oval shape which is partly masked so that the nose is visible again. In this case, mouse tests that would lead to a successful hit within the masked area of that shape should be ignored and "fall through" to underlying objects.
Assignee: nobody → till
This might be a dupe of hit testing bug 1073401.
Blocks: 1037568
Keywords: regression
(Assignee)

Comment 3

4 years ago
Fixed by https://github.com/mozilla/shumway/pull/1783

(In reply to Chris Peterson (:cpeterson) from comment #2)
> This might be a dupe of hit testing bug 1073401.

Surprisingly, it turned out to be completely unrelated - expect for being caused by the same patch.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.