Hovering over links in SVG don't cause cursor to change

RESOLVED FIXED in Firefox 33

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: keith.s.wilkinson, Assigned: longsonr)

Tracking

({regression})

32 Branch
mozilla35
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox32 wontfix, firefox33+ fixed, firefox34 fixed, firefox35 fixed, firefox-esr31 unaffected)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

1. Display http://travel-tokyo.info/Shinjuku.svg 
    or drag and drop this SVG file onto Firefox. 
2. Hover over the link http://travel-tokyo.info in top left corner. 




Actual results:

Cursor does not change to indicate that the link is clickable. 


Expected results:

Works as expected in Internet Explorer, but I don't know what the SVG spec. says.

Comment 1

5 years ago
Regression range:
good=2014-05-26
bad=2014-05-27
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e86a0d92d174&tochange=cbe4f69c2e9c

Maybe one of these bugs about removing style sheet on-demand for SVG documents.
Keywords: regression

Comment 2

5 years ago
Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b42ec325e34d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140524122823
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/feff69cd698f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140524130923
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b42ec325e34d&tochange=feff69cd698f

Regressed by: Bug 1013936
Blocks: 1013936

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 3

5 years ago
Posted patch pointer.txtSplinter Review
I did think about creating a common.css and loading that always. Would you have preferred that?
Attachment #8496580 - Flags: review?(jwatt)
Assignee

Updated

5 years ago
Assignee: nobody → longsonr
Drive-by nit: Might be nice to add/extend a comment to make it clearer that these rules are expected to exactly match the corresponding rules in ua.css (and maybe have a comment in ua.css saying the same).

That way, if we have to update these rules in one spot for some reason, we'll know that we should probably also update the other spot.
OS: Windows 7 → All
Hardware: x86_64 → All
Comment on attachment 8496580 [details] [diff] [review]
pointer.txt

Review of attachment 8496580 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!

::: layout/svg/svg.css
@@ +75,5 @@
>    opacity: inherit;
>  }
>  
> +/* nsDocumentViewer::CreateStyleSet doesn't load ua.css
> + * a few styles are common to html and SVG though

Append ", so we copy the rules below from that file."
Attachment #8496580 - Flags: review?(jwatt) → review+
I was essentially going for what Daniel said. Feel free to expand on my suggested change to more fully address that.
[Tracking Requested - why for this release]:
Requesting tracking for Firefox 33 -- this was a regression that shipped in Firefox 32 that can break interaction in SVG documents / SVG-based webapps (by not making it clear that links are clickable).  Looks like the fix should be easily & safely backportable, and it'd be nice to have this fixed in 33, so that it's only broken for one release.
A low risk fix for this will have to land today.
Flags: needinfo?(longsonr)
Flags: needinfo?(dholbert)
Assignee

Updated

5 years ago
Flags: in-testsuite+
Assignee

Comment 11

5 years ago
Approval Request Comment
[Feature/regressing bug #]: bug 1013936
[User impact if declined]: link cursor incorrect
[Describe test coverage new/current, TBPL]: patch includes mochitest
[Risks and why]: very low, just restores the old link link handling css
[String/UUID change made/needed]: none
Attachment #8496722 - Flags: approval-mozilla-beta?
Attachment #8496722 - Flags: approval-mozilla-aurora?
Comment on attachment 8496722 [details] [diff] [review]
as landed on inbound

Approving even it is not in m-c to make sure it is in beta 8
Attachment #8496722 - Flags: approval-mozilla-beta?
Attachment #8496722 - Flags: approval-mozilla-beta+
Attachment #8496722 - Flags: approval-mozilla-aurora?
Attachment #8496722 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/fb41517a5009
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Flags: needinfo?(dholbert)

Updated

5 years ago
Depends on: 1075479

Updated

5 years ago
No longer depends on: 1075479
You need to log in before you can comment on or make changes to this bug.