[e10s] The devtools are slow to open with e10s enabled

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: daniel.nr01, Unassigned)

Tracking

(Blocks 2 bugs)

35 Branch
x86_64
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [e10s-m7])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140927030204

Steps to reproduce:

The devtools are slow to open with e10s enabled. To reproduce hit ctrl + shift + i to toggle open the devtools


Actual results:

The time from keypress to fully rendered toolbox is 2-3 s.


Expected results:

It should be as quick as without e10s enabled, less than 1 s.
Component: Untriaged → Developer Tools
Summary: The devtools are slow to open with e10s enabled → [e10s] The devtools are slow to open with e10s enabled
Ctrl+Shift+I will open your last used tool. It's likely the tool itself that is slow to load, and not the devtools toolbox itself. Which tool in particular did you have open?
(In reply to Heather Arthur  [:harth] from comment #1)
> Ctrl+Shift+I will open your last used tool. It's likely the tool itself that
> is slow to load, and not the devtools toolbox itself. Which tool in
> particular did you have open?

i.e. Inspector, Console, etc.?
It seems to apply to all tools (at least inspector, console, debugger). It's as if the rendering in general is slower. Also opening any tool and then clicking on another (not yet used) tool there is a flash of a white background and a delay, which I've not noticed without e10s.
These DevTools bugs should probably block e10s from riding to Aurora.
devtools bugs will block the e10s merge to Aurora, but blassey would like them to be tracked by dte10s meta bug 875871, not the tracking-e10s=m6+ flag.
Whiteboard: [e10s-m6]
Whiteboard: [e10s-m6] → [e10s-m7]
I have been trying this on and off on different pages using the nightly on Windows and Mac, but I haven't noticed a difference in the time it takes to show the last developer tool used while using the browser in e10s mode vs not.

However, since developer tools are a highlight of Dev Edition, should it be tracked for e10s m6?
Brian: Do you think this is still a problem?
Flags: needinfo?(bgrinstead)
(In reply to Joe Walker [:jwalker] (overloaded - needinfo me or ping on irc) from comment #7)
> Brian: Do you think this is still a problem?

We have data about this :).  jmaher has run a test - see https://bugzilla.mozilla.org/show_bug.cgi?id=1144120#c8 and https://pastebin.mozilla.org/8840313.  The talos results (which include toolbox open, page reload with toolbox open, and toolbox close) indicate that things are actually now around the same or even improved in e10s.  The most significant result looks like Win7, which is showing an 8.5% improvement with this particular test data.

So, should be safe to mark this one as fixed.

   test      Master     gmean      stddev       points    change
Linux:
   damp      259.4 +/-  1% (6#)    [+0.3%]     260.2 +/-  1% (6#)

Linux64:
:) damp      241.6 +/-  1% (6#)    [-1.0%]     239.1 +/-  1% (6#)

Win7:
:) damp      240.2 +/-  1% (6#)    [-8.5%]     219.7 +/-  1% (6#)

WinXP:=
:) damp      208.7 +/-  1% (6#)    [-3.4%]     201.5 +/-  1% (6#)

Win8:
:) damp      232.9 +/-  0% (6#)    [-6.9%]     216.9 +/-  1% (6#)

OSX10.10:
   damp      330.2 +/-  8% (6#)    [-3.2%]     319.5 +/-  6% (6#)
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bgrinstead)
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.