crash (infinite loop) when closing tab

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: lior31415, Assigned: hyatt)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    mozilla-0.9.5 . can't determine the build ID - title bar has page title

opening two new tabs in succession, then closing the first of these two leads to
an infinite loop. This happens when browsing the above website
(Ha'aretz newpaper flash news) today.

I have successfully opened and closed tabs on this website before.

Reproducible: Always
Steps to Reproduce:
1. Go to the above page (Ha'aretz newpaper flash news in Hebrew).
In the middle of the page there are links to individual stories.

2. Open one in a tab. You now have 2 tabs (headlines + story). Then return to
the headlines page and open another in a third tab.

3. By now, the first tab should have finished loading. Go there, read the story
(if you're interested), and close this tab (using the right mouse button on the
tab title).

Actual Results:  You should now be experiencing an infinite loop

Expected Results:  closed the tab and returned to one of the other tabs.

This could be due to a recent change in the way Ha'aretz produce their
web pages -- I have successsfully used the tabbing feature with this
site before.
(Reporter)

Comment 1

17 years ago
Created attachment 55583 [details]
gdb stack trace produce by interrupting program
(Reporter)

Comment 2

17 years ago
Created attachment 55588 [details]
tracked crash with /usr/bin/strace.
(Reporter)

Comment 3

17 years ago
More attempts:

Sometimes the first new tab closes fine, but the second one produces the problem.
Sometimes there is a crash instead of an infinite loop. Might depend on the
choice of stories.

Comment 4

17 years ago
Please try with a newer build, tabbed browsing has had a lot of bugfixes since
0.9.5. Could not reproduce with 2001102608, linux.. 
worksforme.  Please reopen if you can reproduce with a recent build (a nightly 
or the soon-to-be-released 0.9.7).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.