Improper indic font on Mac OSX

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: rohandhruva, Unassigned)

Tracking

32 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8496636 [details]
Screen Shot 2014-09-28 at 5.45.42 PM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Open this URL: https://www.facebook.com/photo.php?fbid=10204507138262031&set=p.10204507138262031&type=1&permPage=1


Actual results:

Bad font rendering of the Hindi Font


Expected results:

Font rendering should be proper, attaching Chrome screenshot for example.

Updated

4 years ago
Component: Untriaged → Graphics: Text
Product: Firefox → Core
This is not a Firefox bug. The problem here occurs because the text in that comment is encoded incorrectly: it uses the pair of characters <U+093E VOWEL SIGN AA, U+0947 VOWEL SIGN E> to represent the o-matra, where it should use U+094B VOWEL SIGN O.

Or more visually, that comment encodes the letter ो using the two separate pieces ा and  े.

This just happens to render "OK" in Chrome because it's using the Devanagari Sangam MN font by default for Devanagari, but fails in Firefox because it's using Devanagari MT. If you copy/paste the text into TextEdit, for example, and change between these two fonts you'll see the same behavior.

You could "fix" the problem in Firefox by changing the browser preferences to prefer Devanagari Sangam MN as the default Devanagari font, but the real problem is that this text is incorrectly encoded. It will also display badly with most OpenType fonts on non-Mac platforms; in many cases, it'll render with an additional dotted circle, as "ा◌े".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.