[Dialer] When user touch many keypad at the same time, add contact button is not worked immediately

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Dialer
--
major
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: promise09th, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 unaffected)

Details

(Whiteboard: [LibGLA,TD102019,QE2,C])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
1. Title : When user touch many keypad at the same time, add contact button is not worked immediately
2. Precondition : Run dialer app and enter keypad screen
3. Tester's Action : 
 1) Touch keypad(select keypad 3~4 buttons at the same time)when device fill out input(more 50 digits)
 2) Select add contact button
4. Detailed Symptom : Add contact button is not worked immediately. After some time, add contact button is worked
5. Expected : Add contact button is worked immediately.
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Mozilla Frame : Reproduced (v2.0 9/24)
(Reporter)

Updated

3 years ago
Whiteboard: [LibGLA,TD102019,QE2,C]
(Reporter)

Comment 1

3 years ago
Created attachment 8496646 [details]
Bug_1074020.3gp
Confirmed on:
Gaia-Rev        5c2303ec4e367da060aa1b807d541a6549b3d72a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/44f813760b88
Build-ID        20140928160203
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140925.032857
FW-Date         Thu Sep 25 03:29:07 EDT 2014
Bootloader      L1TC10011800

I tested after entering the 50 digits one by one, no issue to report. This looks like a performance issue. Do you confirm Rik?
Status: UNCONFIRMED → NEW
status-b2g-v2.0: --- → affected
Ever confirmed: true
Flags: needinfo?(anthony)
That doesn't look like a performance issue to me. The button looks enabled.

Which device is this reproduced on? Could it be a driver issue?
Flags: needinfo?(anthony)
(Reporter)

Comment 4

3 years ago
I test mozilla frame device. 
When I press the number button at the same time, this issue is reproduced.
Please check video
(In reply to Anthony Ricaud (:rik) from comment #3)
From my side, tested on the Flame KK image.
I'm not able to repro on 2.1 (tried 5 times).
Gaia-Rev        a00d102abfe8ae15c4fd14771efa2335c6d3b8d9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/cde28bd9a285
Build-ID        20140930000203
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140930.042005
FW-Date         Tue Sep 30 04:20:16 EDT 2014
Bootloader      L1TC10011800

Hence, it's already fixed on a later version and 2.0 is only open for blockers. So, as this issue is also an edge case, we won't fix this issue in 2.0. If you think this is an error, please reopen.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.1: --- → unaffected
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.