Closed Bug 1074024 Opened 5 years ago Closed 5 years ago

[D3D9] Black rectangle appears since Firefox33.0ab7 (Force use D3D9)

Categories

(Core :: Graphics: Layers, defect, blocker)

33 Branch
x86_64
Windows 7
defect
Not set
blocker

Tracking

()

VERIFIED FIXED
mozilla33
Tracking Status
firefox32 --- unaffected
firefox33 --- verified
firefox34 --- unaffected
firefox35 --- unaffected

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image screenshot
[Tracking Requested - why for this release]: Regression: graphic glitch

I am trying to reproduce of the graphics glitch in Bug 1073881.
And I found the one of condition. 
I am not sure the combination of Direct2D and D3D9 is allowed or not.

Force use D3D9
Force enable Direct2D


Steps To Reproduce:
1. Make sure the following preferences is in user.js
   user_pref("layers.prefer-d3d9", true);
   user_pref("gfx.direct2d.force-enabled", true);

2. Open about:addons and scroll

Actual Results:
Black rectangle appears 

Regression window(beta)
Good:
https://hg.mozilla.org/releases/mozilla-beta/rev/7c118b1cf343
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140923120744
Bad:
https://hg.mozilla.org/releases/mozilla-beta/rev/2431af782661
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140923142743
Pushlog:
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=7c118b1cf343&tochange=2431af782661

Regressed by: 
280407351f1b	Matt Woodrow — Bug 1030147 - Release the DrawTarget to drop the surface ref in ThebesLayerD3D9. r=Bas a=lmandel CLOSED TREE
Summary: Black rectangle appears on Firefox33.0ab7 → Black rectangle appears on Firefox33.0ab7 (Force use D3D9, Force enable Direct2D)
Status: NEW → UNCONFIRMED
Ever confirmed: false
Aha, not necessary Direct2D force enabled.
Just D3D9 force enabled.


Steps To Reproduce:
1. Make sure the following preferences is in user.js
   user_pref("layers.prefer-d3d9", true);

2. Open about:addons and scroll
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Black rectangle appears on Firefox33.0ab7 (Force use D3D9, Force enable Direct2D) → Black rectangle appears on Firefox33.0ab7 (Force use D3D9)
Summary: Black rectangle appears on Firefox33.0ab7 (Force use D3D9) → [D3D9] Black rectangle appears on Firefox33.0ab7 (Force use D3D9)
Regression window(beta)
Good;
https://hg.mozilla.org/releases/mozilla-beta/rev/5e2a5b6c7a0d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140923072243
Bad(crash):
https://hg.mozilla.org/releases/mozilla-beta/rev/f631df57b34c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140923110143
Pushlog;
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=5e2a5b6c7a0d&tochange=f631df57b34c
Regressed by:
f631df57b34c	Bas Schouten — Bug 1030147 - Switch off OMTC on windows. r=milan, a=sylvestre



Progression(fixed crash) window(beta)
Bad(crash):
https://hg.mozilla.org/releases/mozilla-beta/rev/7c118b1cf343
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140923120744
Bad:(graphic glitch
https://hg.mozilla.org/releases/mozilla-beta/rev/2431af782661
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140923142743
Pushlog:
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=7c118b1cf343&tochange=2431af782661

Regressed by: 
280407351f1b	Matt Woodrow — Bug 1030147 - Release the DrawTarget to drop the surface ref in ThebesLayerD3D9. r=Bas a=lmandel CLOSED TREE
I think this is blocker bug.
Severity: critical → blocker
Summary: [D3D9] Black rectangle appears on Firefox33.0ab7 (Force use D3D9) → [D3D9] Black rectangle appears since Firefox33.0ab7 (Force use D3D9)
We did an experiment to turn back off omtc in beta 7 to see the impact on crash rate.
We are probably going to turn it back on in bug 1074045. It should fix this bug.
Depends on: 1074045
I can confirm that it was fixed in latest tinder-box beta.
https://hg.mozilla.org/releases/mozilla-beta/rev/b9e8ce2a141b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140929074000
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Flags: qe-verify+
Easily reproduced the issue on Win 7 x64 with steps from comment 1, using Firefox 33 Beta 7. No longer reproduced on Firefox 33 Beta 9: User Agent=Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0, BuildID=20141002185629.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.