Closed Bug 1074061 Opened 7 years ago Closed 7 years ago

[Costcontrol]Text and checkbox is shown so transparent.

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: vsireesha246, Assigned: vsireesha246)

Details

(Whiteboard: [LibGLA,TD102364,QE2, B])

Attachments

(2 files, 1 obsolete file)

Steps to Reproduce:

1.Open Usage app and configure it
2.Disable the Mobile usage check box
3.Check the Text and check boxes

Actual:So transparent

Expected:The text and check box should be dark.
Whiteboard: [LibGLA,TD102364,QE2, B]
Hi Sireesha, 
This behaviour is correct. When the checkbox is disabled the text and the checkbox are transparent.

Regards
Attached patch V2.0_Bug_1074061.patch (obsolete) — Splinter Review
Hi Mai,

Please see the behavior of enabling and disabling check box below.

Music - select any music file - Share - Ringtones - reserve Use default ringtone text and checkbox.

Please review the attached patch,if you are fine with this patch i will upload PR.
Attachment #8496741 - Flags: review?(mri)
Hi Eric,
would you mind review the behaviour of the wifi and mobile checkboxes.

Regards
Flags: needinfo?(epang)
(In reply to Marina Rodríguez [:mai] from comment #3)
> Hi Eric,
> would you mind review the behaviour of the wifi and mobile checkboxes.
> 
> Regards

Hi Marina, I'm not the designer of the usage app, but the behavior does seem strange to me as well.  I would expect it to behave like the settings app where only the inner blue and check mark turns on and off.
Flags: needinfo?(epang)
Hi Kcaldwell,

Would you please do the UX review for this issue and let me know is this patch behavior is correct

Thanks..
Sireesha
Flags: needinfo?(kcaldwell)
Hi Sireesha,

Text and checkbox should not be transparent. The only change should be the state of the checkbox - checked (enabled/on) or unchecked (disabled/off). No transparency of the checkbox when unchecked - the checkbox, visually, should appear as a blue outline, as mentioned above in comment #2.
Flags: needinfo?(kcaldwell)
Comment on attachment 8496741 [details] [diff] [review]
V2.0_Bug_1074061.patch

Review of attachment 8496741 [details] [diff] [review]:
-----------------------------------------------------------------

Works fine.
Thanks Sireesha

PS: Please, attach the pr link.
Attachment #8496741 - Flags: review?(mri) → review+
Thanks Mai,by coming monday i will be post PR.

(In reply to Marina Rodríguez [:mai] from comment #7)
> Comment on attachment 8496741 [details] [diff] [review]
> V2.0_Bug_1074061.patch
> 
> Review of attachment 8496741 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Works fine.
> Thanks Sireesha
> 
> PS: Please, attach the pr link.
Hi Mai,

Would you please recheck this PR and if it is fine please merge to master.

Thanks..
Sireesha
Attachment #8496741 - Attachment is obsolete: true
Flags: needinfo?(mri)
Attachment #8500267 - Flags: review+
Flags: needinfo?(mri)
Master:bc12af50fe33ed794d72fc5acfeef94e75169ae0
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8500267 [details]
Pointer to Pull Request.html

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature
[User impact] if declined: Bad UX, the user cannot see the mobile consume because when the checkbox is disabled, the info related with the traffic is hide.
[Testing completed]: Yes, on device
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]: No
Attachment #8500267 - Flags: approval-gaia-v2.1?(release-mgmt)
Attachment #8500267 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/1e72b5bc019766b6355b93bb8d77c9e99c3e375e
Assignee: nobody → vsireesha246
Target Milestone: --- → 2.1 S6 (10oct)
Attached video Verify_Video_Flame.MP4
This issue has been verified successfully on Flame 2.1 & 2.2.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.1 version:
Gaia-Rev        db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/211eae88f119
Build-ID        20141126001202
Version         34.0

Flame 2.2 version:
Gaia-Rev        824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/acde07cb4e4d
Build-ID        20141125040209
Version         36.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.