--with-pthreads (and any other --with-* bool) broken

VERIFIED DUPLICATE of bug 107055

Status

SeaMonkey
Build Config
--
critical
VERIFIED DUPLICATE of bug 107055
17 years ago
13 years ago

People

(Reporter: jesup, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
After this weekend, --with-pthreads is broken (fails in configure).  The problem
is that AC_ARG_WITH sets $withval, but MOZ_TWO_STRING_TEST tests $enableval(!!!)
(These macros are in altoptions.m4)

This affects all other --with-* booleans, though since by then enableval is set,
they may continue (but possibly select the wrong option).

I have a patch (make MOZ_TWO_STRING_TEST take an argument for the variable to
test) that I'm going to try.

This breaks a lot of build options!!!!!
(Reporter)

Comment 1

17 years ago
Created attachment 55592 [details] [diff] [review]
Patch to use correct variable names
(Reporter)

Comment 2

17 years ago
Args broken by the with/enable bug:

--with-pthreads
--without-system-nspr
--with-static-gtk
--with-static-qt
--with-os2vacpp
--without-libidl

If there are other configure.in's (in nspr, etc) they may have options that were
broken as well.

*** This bug has been marked as a duplicate of 107055 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.