[NFC][KK] Background of shrinking UI would show app icons if website has ever been run at the background

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ashiue, Assigned: gduan)

Tracking

unspecified
2.1 S6 (10oct)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Gaia-Rev        13973ab50760d1e8bb773082163f0dff19d35a44
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/6e317e075d04
Build-ID        20140928160204
Version         34.0a2

STR:
1. Enable NFC on both phones
2. Open a website
3. Press home button that let the website running at the background
4. Long press home button and select website that let the website running at the foreground
5. Tap two phone together and check the shrinking UI

Expect result:
Shrinking UI shows correcly

Actual result:
Background of shrinking UI would show app icons (http://youtu.be/pXlv66vgswA)
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
Obvious error
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=NFC]
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → unaffected
Assignee: nobody → gduan
triage: impact lots of users. 

(Check the http://youtu.be/pXlv66vgswA at 15 sec)
blocking-b2g: 2.1? → 2.1+
Created attachment 8497379 [details] [review]
PR to 2.1

Hi Alive,
comparing with master, I think the root cause is, when we launch cardview, we didn't close the homescreen app, so I copy part of code from bug 1061324. Could I have your feedback on this patch? I will add tests later if it's ok.
Attachment #8497379 - Flags: feedback?
Attachment #8497379 - Flags: feedback? → feedback?(alive)
Comment on attachment 8497379 [details] [review]
PR to 2.1

Sam, please give some advise here for why we have difference between v2.1 and master.
Attachment #8497379 - Flags: feedback?(alive) → feedback?(sfoster)
Flags: needinfo?(sfoster)
Comment on attachment 8497379 [details] [review]
PR to 2.1

Forwarding along to Aus who is more familiar with this code then I at this point
Attachment #8497379 - Flags: feedback?(sfoster) → feedback?(aus)
Flags: needinfo?(sfoster)
> Sam, please give some advise here for why we have difference between v2.1
> and master.

The difference exists because we didn't get uplift approval for bug 1061324 (it was completed too late and risk deemed to high)

Comment 7

4 years ago
Comment on attachment 8497379 [details] [review]
PR to 2.1

I think this is going the right direction, I left some comments in the pull request. This will need tests to cover those three code paths as well.
Attachment #8497379 - Flags: feedback?(aus) → feedback+
Comment on attachment 8497379 [details] [review]
PR to 2.1

Hi Alive,
could you review this patch for v2.1?
Thanks.
Attachment #8497379 - Flags: review?(alive)
Comment on attachment 8497379 [details] [review]
PR to 2.1

I personally think we (:aus, :sfoster) should find some time to discuss about code pattern here, but for now let's do the same thing as master.
Attachment #8497379 - Flags: review?(alive) → review+
Created attachment 8498587 [details] [review]
PR to 2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): No.
[User impact] if declined: see video in comment 0.
[Testing completed]: Yes.
[Risk to taking this patch] (and alternatives if risky): None.
[String changes made]:
Attachment #8498587 - Flags: approval-gaia-v2.1?
(Reporter)

Comment 11

4 years ago
Hi Bhavana, 

Could you please check if you could approve this approval request? Thank you very much.
Flags: needinfo?(bbajaj)
Looks like the patch is ready and waiting for approval.
Set the target milestone to end of this week.
Target Milestone: --- → 2.1 S6 (10oct)
Attachment #8498587 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Comment on attachment 8498587 [details] [review]
PR to 2.1

Hm, please ask for approval only on fixed bugs.
Attachment #8498587 - Flags: approval-gaia-v2.1+
There were many pr closed for tree stability, so I open another PR for it, code are the same.

(In reply to George Duan [:gduan] [:喬智] from comment #10)
> Created attachment 8498587 [details] [review]
> PR to 2.1
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): No.
> [User impact] if declined: see video in comment 0.
> [Testing completed]: Yes.
> [Risk to taking this patch] (and alternatives if risky): None.
> [String changes made]:
Comment on attachment 8498587 [details] [review]
PR to 2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): No.
[User impact] if declined: see video in comment 0.
[Testing completed]: Yes.
[Risk to taking this patch] (and alternatives if risky): None.
[String changes made]:
Attachment #8498587 - Flags: approval-gaia-v2.1?
Attachment #8498587 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
2.1: https://github.com/mozilla-b2g/gaia/commit/d71f8804d7229f4b354259d5d8543c25b4796064
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1074029
status-b2g-v2.1: affected → fixed
Flags: needinfo?(bbajaj)
(Reporter)

Comment 18

4 years ago
Verified on
Gaia-Rev        55ce3612bd8a8665139d6b85114ce59993a3fa0a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/8811060bf3fe
Build-ID        20141008160203
Version         34.0a2
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
Depends on: 1079995
You need to log in before you can comment on or make changes to this bug.