[Dialer] Call error popup is not translated when user change language

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
4 years ago
7 months ago

People

(Reporter: promise09th, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [LibGLA,TD103215,QE2,A])

(Reporter)

Description

4 years ago
1. Title : Call error popup is not translated when user change language
2. Precondition : 
3. Tester's Action :
 1) Turn on airplane mode
 2) Run dialer
 3) Input number, and select call button
 4) Check popup
 5) Press home key
 6) Run Settings app > Language > Change other language
 7) Run dialer again
4. Detailed Symptom : String is not translated
5. Expected : String is not translated
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Mozilla Frame : Reproduce ( v2.0 9/24 )
(Reporter)

Updated

4 years ago
Whiteboard: [LibGLA,TD103215,QE2,C]
I don't think we support the on-the-fly translation of pop ups, do we Doug?
Flags: needinfo?(drs+bugzilla)
(Reporter)

Updated

4 years ago
Whiteboard: [LibGLA,TD103215,QE2,C] → [LibGLA,TD103215,QE2,A]
(In reply to Johan Lorenzo [:jlorenzo] from comment #1)
> I don't think we support the on-the-fly translation of pop ups, do we Doug?

Actually, we do, as long as we use the new l10n API. Anywhere we don't is probably because we're using the old one, which would take the form of calls to `navigator.mozL10n.get()`.
Blocks: 1036516
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(drs+bugzilla)

Comment 3

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.