Closed Bug 1074114 Opened 6 years ago Closed 6 years ago

Failure to create JS-implemented webidl component always throws NS_ERROR_FAILURE

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: neil, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(1 file)

I was trying to debug an error whereby accessing navigator.mozApps throws NS_ERROR_FAILURE in Thunderbird.

Fortunately I found a changeset in between where navigator.mozApps broke and where it got converted to webidl where the global navigator property code propagated the actual error, which gave me a chance to debug it.

It would have been nice if you had actually propagated the error instead of just unhelpfully throwing NS_ERROR_FAILURE.
Attached patch Possible patchSplinter Review
Attachment #8496795 - Flags: feedback?(peterv)
Comment on attachment 8496795 [details] [diff] [review]
Possible patch

Makes sense to me.  r=me
Attachment #8496795 - Flags: feedback?(peterv) → feedback+
McMerge missed this because I wasn't assigned.

https://hg.mozilla.org/mozilla-central/rev/7787a8038654
Assignee: nobody → neil
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Component: DOM → DOM: Core & HTML
Type: enhancement → defect
You need to log in before you can comment on or make changes to this bug.