Missing international prefix in MMS message

RESOLVED INVALID
(NeedInfo from)

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: fjcs, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
When sending a MMS with international prefix, the message arrives without it.

Steps to reproduce:
1- Open Messages application
2- Create a new message and introduce a phone number with +<prefix>, i.e.: +34620971426.
3- Attach a picture to convert to MMS
4- Send the message
5- The message will arrive from the number: +620971426, which, in this case, is not a valid Spanish phone number, and cannot respond to it.
(Reporter)

Updated

4 years ago
Flags: needinfo?(borja.bugzilla)
Francisco, can you please share the Firefox OS version you use?

We'll also need you to add debug information following the steps at https://github.com/bevis-tseng/Debug_Tools, otherwise we can't help much more.

Thanks !
Flags: needinfo?(borja.bugzilla) → needinfo?(fjcs)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
To be more specific, may I know:
1. What's the OS of the sending and receiving party?
2. Is the reproducible by other reference phone under the same network?
3. Can we have the logcat & tcpdump of step#5 of the received party (if it's running FFOS) to see if the number was incorrectly provided from network or was decoded improperly by our PDU parser?

Thanks!
You need to log in before you can comment on or make changes to this bug.