crash in java.lang.NullPointerException: at org.mozilla.gecko.GeckoAppShell.enableNetworkNotifications(GeckoAppShell.java)

RESOLVED DUPLICATE of bug 1074189

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 1074189
4 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: wesj)

Tracking

({crash})

35 Branch
All
Android
crash
Points:
---

Firefox Tracking Flags

(firefox35 affected, fennec34+)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-65416b1b-92b6-47ff-89ca-d9ff42140928.
=============================================================

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoAppShell.enableNetworkNotifications(GeckoAppShell.java:2450)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:365)
	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:186)

Regression from bug 1024614?
It looks like we call GeckoNetworkManager.destroy() (which nulls the sInstance) in GeckoApp.onDestroy(), but nothing ever creates a new instance. Looks like :wesj broke this in bug 1061030.
Assignee: nobody → wjohnston
Depends on: 1061030
(Reporter)

Updated

4 years ago
Blocks: 1061030
No longer depends on: 1061030
Duplicate of this bug: 1074881
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoAppShell.enableNetworkNotifications(GeckoAppShell.java)] → [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoAppShell.enableNetworkNotifications(GeckoAppShell.java)] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApplication.onActivityPause(GeckoApplication.java)]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074189
tracking-fennec: ? → 34+
You need to log in before you can comment on or make changes to this bug.