Convert nsSVGPathGeometryFrame::Render() to render directly using the Moz2D DrawTarget

RESOLVED FIXED in mozilla35

Status

()

Core
SVG
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: jwatt, Assigned: jwatt)

Tracking

(Blocks: 2 bugs, {perf})

Trunk
mozilla35
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Comment hidden (empty)
(Assignee)

Comment 1

4 years ago
Created attachment 8496958 [details] [diff] [review]
part 1 - Convert SVGAutoRenderState to act on a Moz2D DrawTarget
Attachment #8496958 - Flags: review?(longsonr)
(Assignee)

Comment 2

4 years ago
Created attachment 8496959 [details] [diff] [review]
part 2 - Finish the conversion of nsSVGPathGeometryFrame::Render to Moz2D
Attachment #8496959 - Flags: review?(longsonr)
(Assignee)

Updated

4 years ago
Attachment #8496959 - Attachment is obsolete: true
Attachment #8496959 - Flags: review?(longsonr)
(Assignee)

Updated

4 years ago
Summary: Finish the conversion of nsSVGPathGeometryFrame::Render to Moz2D → Convert nsSVGPathGeometryFrame::Render() to render directly using the Moz2D DrawTarget
(Assignee)

Comment 3

4 years ago
Created attachment 8496998 [details] [diff] [review]
part 2 - Convert nsSVGPathGeometryFrame::Render() to render directly using the Moz2D DrawTarget
Attachment #8496998 - Flags: review?(longsonr)
Attachment #8496958 - Flags: review?(longsonr) → review+
Comment on attachment 8496998 [details] [diff] [review]
part 2 - Convert nsSVGPathGeometryFrame::Render() to render directly using the Moz2D DrawTarget

>   if ((aRenderComponents & eRenderFill)) {

Nit: don't need two brackets here. Since you're changing this area anyway.
Attachment #8496998 - Flags: review?(longsonr) → review+
(Assignee)

Updated

4 years ago
Depends on: 1074475
(Assignee)

Comment 5

4 years ago
Comment on attachment 8496958 [details] [diff] [review]
part 1 - Convert SVGAutoRenderState to act on a Moz2D DrawTarget

https://hg.mozilla.org/integration/mozilla-inbound/rev/7879734700ce
Attachment #8496958 - Flags: checkin+
(Assignee)

Comment 6

4 years ago
Comment on attachment 8496998 [details] [diff] [review]
part 2 - Convert nsSVGPathGeometryFrame::Render() to render directly using the Moz2D DrawTarget

https://hg.mozilla.org/integration/mozilla-inbound/rev/cd87b4cb26c1
Attachment #8496998 - Flags: checkin+
https://hg.mozilla.org/mozilla-central/rev/7879734700ce
https://hg.mozilla.org/mozilla-central/rev/cd87b4cb26c1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1072339
(Assignee)

Updated

4 years ago
Blocks: 703159
(Assignee)

Updated

4 years ago
Blocks: 609361
(Assignee)

Comment 9

4 years ago
This improved performance on bug 609361's testcase by an order of magnitude (see bug 609361 comment 39), and bug 554004's testcase by about 15% (see bug 554004 comment 14).
Blocks: 554004
Keywords: perf
Depends on: 1117514
You need to log in before you can comment on or make changes to this bug.