Closed Bug 1074317 Opened 5 years ago Closed 5 years ago

Report indirect LSan leaks on TBPL

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(firefox42 fixed)

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: mccr8, Assigned: mccr8)

References

(Blocks 1 open bug)

Details

(Whiteboard: [MemShrink:P2])

Attachments

(1 file, 2 obsolete files)

Right now on TBPL, we don't report indirect leaks.  I figured they couldn't be that bad, and we were getting some persistent small ones in XPConnect, so I just left it alone.  Nick told me this was a bad idea, but hey, how bad could it get?  

It turns out, pretty bad.  I just noticed bug 1074310, where we have 22mb of indirect leaks.  I guess some global data is entraining leaking media stuff.  Anyways, the main difficulty here will be fixing the existing leaks.  Then I should be able to enable this pretty easily.
Depends on: 1074416
Whiteboard: [MemShrink] → [MemShrink:P2]
Depends on: 1189430
Depends on: 1189568
I've now filed all of the indirect leaks we have on TreeHerder. I'll probably add suppressions for them if something concrete doesn't happen with them soon.
I haven't tested this yet.
LeakSanitizer reports two kinds of leaks: direct and indirect. I think that "direct" means that no other leaked block points to the leaked block, while "indirect" means that some other leaked block points to the leaked block. Right now, we don't turn the tree orange for indirect leaks because that was easier to get landed. Most of the time, indirect leaks are just stuff that is entrained by other leaks. However, if two blocks point to each other, then they are reported as indirect, and so we aren't seeing them. The changes to leak.py just make it so that indirect leaks are handled the same as direct leaks. I also added some suppressions for the three indirect leaks I see, which is maybe the more interesting part here. Let me know if you have any questions, Eric.

try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=81d04047a473
Attachment #8642406 - Flags: review?(erahm)
Assignee: nobody → continuation
Attachment #8641941 - Attachment is obsolete: true
I added some more explanation to the patch comment.
Attachment #8642406 - Attachment is obsolete: true
Attachment #8642406 - Flags: review?(erahm)
Attachment #8642410 - Flags: review?(erahm)
Comment on attachment 8642410 [details] [diff] [review]
Report indirect LSan leaks in mochitests.

Review of attachment 8642410 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #8642410 - Flags: review?(erahm) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/346ee08c3974
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Duplicate of this bug: 1156112
You need to log in before you can comment on or make changes to this bug.