Twitter app stopped working. (can't login)

RESOLVED WORKSFORME

Status

Firefox OS
Gaia
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: gwagner, Unassigned)

Tracking

({regression})

unspecified
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
On current 2.1 build.
When trying to sign into twitter I see a white screen and it goes back to the main page again.
(Reporter)

Updated

4 years ago
Keywords: regression
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.1+
I am seeing this occur on Flame KK 2.1 and 2.2 devices with almost 100% repro.  I was able to sign in properly one time on 2.1 following a device restart, but every other time resulted in the app showing a blank white screen, then redirecting back to the log-in screen.  The user appears to remain signed in, as they are not asked to input email and password on each subsequent attempt, and are simply redirected to the log-in screen each time they select 'Sign in'
   
Repro Steps:
1) Update a Flame device to BuildID: 20140929000203
2) Download the Twitter app from the Marketplace.
3) Launch the Twitter app from the homescreen.
4) Log in to a Twitter account.
  
Actual:
After logging in, the user is shown a blank white screen, then redirected to the Twitter Log-in page.
  
Expected: 
The user is able to log in properly, and is brought to their twitter feed.
  
Environmental Variables:
Device: Flame 2.1 319MB
BuildID: 20140929000203
Gaia: 063de64a4ffc606e931ed7b09e93282713c46eca
Gecko: 055d46b81ed1
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 9/10
See attached: logcat

------------------------------

This issue DOES occur on Flame 2.2.
User is unable to log in to Twitter.

Environmental Variables:
Device: Flame 2.2 Master 319MB
BuildID: 20140929040202
Gaia: 2834baf4c7e34fe6ef335f0469f6d0f593c5922b
Gecko: 9d66436af432
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(pbylenga)
Created attachment 8497077 [details]
logcat-Twitter_Sign-In.txt
Something's going bad with... appcache! :

"Revision: 2feab77debb5e005d6108f0e4db734bbcf270094" m5.js:14
"appcache: error " error { target: OfflineResourceList, isTrusted: true, NONE: 0, CAPTURING_PHASE: 1, AT_TARGET: 2, BUBBLING_PHASE: 3, ALT_MASK: 1, CONTROL_MASK: 2, SHIFT_MASK: 4, META_MASK: 8, eventPhase: 0 } m5.js:475
"cache: exception on update()"

Not sure if that's on our side or Twitter's
QAWanted to see if this is still reproducible.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
I've been able to successfully log in to Twitter using the Marketplace app, E.Me app, and through the Browser 100% of the time on today's 2.1 build.

Environmental Variables:
Device: Flame 2.1 319MB
BuildID: 20140930000203 (Full Flash)
Gaia: a00d102abfe8ae15c4fd14771efa2335c6d3b8d9
Gecko: cde28bd9a285
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
Gregor, is the issue no longer reproducing for you as well?
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(anygregor)
I can't reproduce either anymore. Closing for now, please reopen if this comes up again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

4 years ago
(In reply to Peter Bylenga [:PBylenga] from comment #6)
> Gregor, is the issue no longer reproducing for you as well?

Yep works again.
Flags: needinfo?(anygregor)
You need to log in before you can comment on or make changes to this bug.