Intermittent Win8 m-bc crash [@ mozilla::ReentrancyGuard::ReentrancyGuard<mozilla::VectorBase<js::GCHelperState *,0,js::SystemAllocPolicy,js::Vector<js::GCHelperState *,0,js::SystemAllocPolicy> > >(mozilla::VectorBase<js::GCHelperState *,0,js::SystemAlloc

RESOLVED DUPLICATE of bug 1051822

Status

()

RESOLVED DUPLICATE of bug 1051822
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({assertion, crash})

Trunk
x86
Windows 8.1
assertion, crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
https://treeherder.mozilla.org/ui/logviewer.html#?job_id=2623703&repo=mozilla-inbound

builder 	WINNT 6.2 mozilla-inbound debug test mochitest-browser-chrome-3
buildid 	20140929094403
builduid 	b9a440a6ccdb4f7999dff5581831dd62
results 	warnings (1)
revision 	da12cd0ebe40
slave 		t-w864-ix-011
starttime 	Mon Sep 29 2014 14:17:29 GMT-0400 (Eastern Standard Time)

11:21:56 INFO - Assertion failure: !mEntered, at c:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\obj-firefox\dist\include\mozilla/ReentrancyGuard.h:39 

11:37:06 WARNING - PROCESS-CRASH | Main app process exited normally | application crashed [@ mozilla::ReentrancyGuard::ReentrancyGuard<mozilla::VectorBase<js::GCHelperState *,0,js::SystemAllocPolicy,js::Vector<js::GCHelperState *,0,js::SystemAllocPolicy> > >(mozilla::VectorBase<js::GCHelperState *,0,js::SystemAllocPolicy,js::Vector<js::GCHelperState *,0,js::SystemAllocPolicy> > &,mozilla::detail::GuardObjectNotifier const &)]
11:37:06 INFO - Crash dump filename: c:\users\cltbld~1.t-w\appdata\local\temp\tmp0kevko.mozrunner\minidumps\ad3dab8d-e174-4977-a4c1-32bbdf34a282.dmp
11:37:06 INFO - Operating system: Windows NT
11:37:06 INFO - 6.2.9200
11:37:06 INFO - CPU: x86
11:37:06 INFO - GenuineIntel family 6 model 30 stepping 5
11:37:06 INFO - 8 CPUs
11:37:06 INFO - Crash reason: EXCEPTION_BREAKPOINT
11:37:06 INFO - Crash address: 0x71031a70
11:37:06 INFO - Assertion: Unknown assertion type 0x00000000
11:37:06 INFO - Thread 0 (crashed)
11:37:06 INFO - 0 mozjs.dll!mozilla::ReentrancyGuard::ReentrancyGuard<mozilla::VectorBase<js::GCHelperState *,0,js::SystemAllocPolicy,js::Vector<js::GCHelperState *,0,js::SystemAllocPolicy> > >(mozilla::VectorBase<js::GCHelperState *,0,js::SystemAllocPolicy,js::Vector<js::GCHelperState *,0,js::SystemAllocPolicy> > &,mozilla::detail::GuardObjectNotifier const &) [ReentrancyGuard.h:da12cd0ebe40 : 39 + 0x3a]
11:37:06 INFO - eip = 0x71031a70 esp = 0x00c6df90 ebp = 0x00c6df90 ebx = 0x02737864
11:37:06 INFO - esi = 0x6f571ec6 edi = 0x71304014 eax = 0x00000000 ecx = 0x6f57ff12
11:37:06 INFO - edx = 0x00c6c394 efl = 0x00200216
11:37:06 INFO - Found by: given as instruction pointer in context
11:37:06 INFO - 1 mozjs.dll!mozilla::VectorBase<js::GCHelperState *,0,js::SystemAllocPolicy,js::Vector<js::GCHelperState *,0,js::SystemAllocPolicy> >::~VectorBase<js::GCHelperState *,0,js::SystemAllocPolicy,js::Vector<js::GCHelperState *,0,js::SystemAllocPolicy> >() [Vector.h:da12cd0ebe40 : 685 + 0x15]
11:37:06 INFO - eip = 0x71125ace esp = 0x00c6df98 ebp = 0x00c6dfb4
11:37:06 INFO - Found by: call frame info
11:37:06 INFO - 2 mozjs.dll!js::GlobalHelperThreadState::~GlobalHelperThreadState() + 0xd
11:37:06 INFO - eip = 0x7113b02e esp = 0x00c6dfbc ebp = 0x00c6dfd8
11:37:06 INFO - Found by: call frame info
11:37:06 INFO - 3 mozjs.dll!_CRT_INIT [crtdll.c : 413 + 0x2]
11:37:06 INFO - eip = 0x71215de6 esp = 0x00c6dfc4 ebp = 0x00c6dfd8
11:37:06 INFO - Found by: call frame info
11:37:06 INFO - 4 mozjs.dll!__DllMainCRTStartup [crtdll.c : 526 + 0x7]
11:37:06 INFO - eip = 0x71215f02 esp = 0x00c6dfe0 ebp = 0x00c6e01c
11:37:06 INFO - Found by: call frame info
11:37:06 INFO - 5 mozjs.dll!_DllMainCRTStartup [crtdll.c : 476 + 0xd]
11:37:06 INFO - eip = 0x71215f7f esp = 0x00c6e024 ebp = 0x00c6e028
11:37:06 INFO - Found by: call frame info
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1051822
You need to log in before you can comment on or make changes to this bug.