Rounding error resizing 73px images to 48px (Twitter avatar)

RESOLVED FIXED

Status

()

Core
Layout: Images
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Antonio Ospite, Unassigned)

Tracking

31 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.1.0
Build ID: 20140903072827

Steps to reproduce:

I loaded a page of one of my tweets, for instance:
https://twitter.com/ao2it/status/516685703343005696

The same result can be achieved with this snippet in an empty HTML page:
<img style="height: 48px; width: 48px;" src="https://pbs.twimg.com/profile_images/1213587141/logo_256x256_bigger.png" />


Actual results:

The avatar image gets clipped on the right and on the bottom: a few rows and columns are missing.

This is more evident because I have a round logo wich uses the full width and height onf the image. With square images the effect is not as visible.


Expected results:

The whole round logo should have been displayed with no clipping.

I could change logo of course, or ask twitter to use an easier to process image instead of the 73px one, but I thought I'd report the issue here anyway.
This sounds a lot like a bug which we should have fixed recently. Can you maybe try a nightly to see if the bug still exists? https://nightly.mozilla.org/

FWIW, I tried both testcases, I compared the rendering in Firefox nightly and in Chrome, they all looked fine to me, but I don't know what you saw on your computer.

I can reproduce a bug where the right part of the circle looks cut off at a certain zoom in Firefox 29, but it is fixed in Firefox nightly. So it seems likely this bug is fixed in nightly.
(Reporter)

Comment 2

3 years ago
Created attachment 8497337 [details]
ao2_twitter_avatar_Firefox31.png

Attached is the rendering on Firefox 31
(Reporter)

Comment 3

3 years ago
Created attachment 8497340 [details]
ao2_twitter_avatar_FirefoxNightly.png

Attached is the rendering with a nightly build.

So the rounding seems to have been fixed indeed, thanks.

Can you point to the specific commit[s] related to the issue?

Thanks,
   Antonio
(I was thinking it might've been fixed by bug 1006123, but if you're hitting it in Firefox 31, this must be some other bug, because that bug was fixed back to Firefox 30.)

In any case, resolving as WORKSFORME per comment 3. (We know it's fixed, though we're not 100% sure what fixed it.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
If it wasn't bug 1006123 then it was likely bug 1043560.
Depends on: 1043560
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.