cannot realign whole list after small part of list was previously aligned

VERIFIED DUPLICATE of bug 102547

Status

()

Core
Editor
P1
normal
VERIFIED DUPLICATE of bug 102547
17 years ago
16 years ago

People

(Reporter: TucsonTester1, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE+; 1 day)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    20011019

after creating a list and you try to align 1-2 lines of the text then reverse 
that, and choose to align the whole list.  The first alignment sticks with 
those 1-2 lines previously chosen instead of doing what the whole list has done.

Reproducible: Always
Steps to Reproduce:
1.open navigator
2.open composer
3.type in at least 2-? lines of text 
4.click on edit and select all
5.then click to make them a list(bullet or numbered)
6.then click away to un-highlight them all
7.select any 1-2 lines of text and highlight them
8.then click center or right to align the text accordingly 
9.then click left to align them back with the rest of the text
10.click edit select all
11.click center align to center or right to align the text again 
12.all but the first 1-2 lines you had previously aligned change to the new 
correct setting.  

Actual Results:  the lines that were previously aligned stay where they were 
set to but the rest of the list moves to the correct new alignment 

Expected Results:  I would expect the new alignment would over-rule the 
previous configuration on 1-2 lines and all text would align in the new setting 
(i.e. center left right)

Comment 1

17 years ago
Evil.

It is like the items that have divs on them are not being pushed over. After the
original list is left-aligned, the li's that were centered and then left aligned
now contain divs that have align="left" ... so it is like the align="left" has
precedence over the operation (hence those li's stay put). The real problem
seems to be that when a li is selected, and we add a div so we can do the
alignment, we don't add divs to all the other elements belonging to the same ul
or ol grouping. Surely we coupld walk the DOM and do that. If I manually insert
the divs, it all works as you might expect.  

This is marginal EDITORBASE. Assigning to jfrancis cause I *think* it is rules
based. I'll let jfrancis determine the fate of this bug from this point on.
Assignee: syd → jfrancis
Component: Editor: Composer → Editor: Core
Summary: cannot realign whole list after small part of list was previously aligned → cannot realign whole list after small part of list was previously aligned
Whiteboard: EDITORBASE

Comment 2

17 years ago
Confirmed on build 2001111603.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

17 years ago
Daniel, is this fixed by your alignment work?
(Assignee)

Comment 4

17 years ago
no, i guess it isn't.  097
Status: NEW → ASSIGNED
Whiteboard: EDITORBASE → EDITORBASE; 1 day
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 5

16 years ago
098
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Comment 6

16 years ago
Lists! My God! Marking p1
Priority: -- → P1
(Reporter)

Comment 7

16 years ago
confirmed again on Mac OS X build 2001121805, changing Platform/OS to all
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Comment 8

16 years ago
pushing off 098 to 099
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Comment 9

16 years ago
alignment should work pretty flawless for users, plussing
Whiteboard: EDITORBASE; 1 day → EDITORBASE+; 1 day

Updated

16 years ago
Keywords: nsbeta1+
(Assignee)

Comment 10

16 years ago
this is a dupe of 102547, which Daniel has a patch for.

*** This bug has been marked as a duplicate of 102547 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 11

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.