[2.1][l10n][Cost Control]Bosnian: The string "Data Report" header is truncated

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: fmuyumba, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [LocRun2.1-1])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8497149 [details]
2014-09-29-17-55-49.png

Description:
When device language is changed to Bosnian, the string "Data report" is truncated in "Cost Control" 


Repro Steps:
1) Update a Flame to 20140929000203
2) Choose Bosnian as the default language 
3) Tap 'Usage' from the home screen
4) Tap 'Next'
5) Observe the header


Actual:
The header "Data report" is NOT truncated


Expected:
The header "Data report" IS truncated

Environmental Variables:
Device: Flame 2.1 KitKat Base (319mb)(Full Flash)
Build ID: 20140929000203
Gaia: 063de64a4ffc606e931ed7b09e93282713c46eca
Gecko: 055d46b81ed1
Version: 34.0a2 
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0



Repro frequency: 100%,
Link to failed test case: https://moztrap.mozilla.org/manage/case/12833/
See attached: screenshot
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
This issue is reproducible on Flame 2.2 KitKat Base (319mb)(Full Flash)

Result: When device language is changed to Bosnian, the string "Data report" is truncated in "Cost Control"

Environmental Variables:
Device: Flame 2.2 KitKat Base (319mb)(Full Flash)
Build ID: 20140929040202
Gaia: 2834baf4c7e34fe6ef335f0469f6d0f593c5922b
Gecko: 9d66436af432
Version: 35.0a1 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

-----------------------------------------------


This CANNOT be tested on Flame 2.0 KitKat Base (319mb)(Full Flash) because it does NOT exist

Environmental Variables:
Device: Flame 2.0 KitKat Base (319mb)(Full Flash)
Build ID: 20140929000203
Gaia: 5c2303ec4e367da060aa1b807d541a6549b3d72a
Gecko: 44f813760b88
Version: 32.0 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Comment 2

4 years ago
The Actual and Expected have been reversed
QA Whiteboard: [QAnalyst-Triage?]
Hey Kerim
I know this is not the best solution, but is there any way to shorten this string (either by taking out a word or abbreviating, if the sense is not lost)? If no workaround is possible, please let me know
Not nominating to block on this issue, simple truncation issue
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.0: unaffected → ---
Flags: needinfo?(dharris)

Comment 5

4 years ago
We can shorten it to "Izvještaj podat. prometa"
Great thanks Kerim!
Can you please submit that change in Pootle and once that's done, mark this bug as resolved fixed?
Then, once you actually see that it looks ok on the device, please mark bug as verified fixed
thanks!

Comment 7

4 years ago
Could anyone give a reference to the exact string on Pootle so that I can fix?
I personally wouldn't know on Pootle but looking at Transvision for this string (http://transvision.mozfr.org/?sourcelocale=en-US&locale=bs&repo=gaia&search_type=entities&recherche=apps/costcontrol/costcontrol.properties:fte-onlydata2-title) I would say the path to that string is: apps ⊃ costcontrol ⊃ costcontrol.properties
Don't know if this helps. If it doesn't let me know and I can ask around

Comment 9

4 years ago
I've changed it on Pootle. Hope it's OK now. Any other stuff I need to change on Pootle?
Thanks Kerim, that should be good. When you do this, please mark the bug as resolved fixed. Once Dwayne pushes your changes on hg and you can actually verify the fix on your device, please mark the bug as verified fixed. Thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.