[2.1][Settings][Bluetooth] The string "Connected to phone audio" is not translated

RESOLVED DUPLICATE of bug 1074166

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1074166
4 years ago
4 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: LocRun2.1-1)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8497152 [details]
logcat_20140929_NotTranslated.txt

Description:
When the device is paired and connected to a bluetooth headset, the string "Connected to phone audio" is not translated when the device is set to a language other than English.

Repro Steps:
1) Updated Flame to Build ID: 20140929000203
2) Set the language to any language other than English.
3) Go to Settings > Bluetooth.
4) Pair with a bluetooth headset.
5) When the devices are paired and connected, observe the "Connected to phone audio" string.

Actual:
The "Connected to phone audio" string is displayed in English.

Expected:
The "Connected to phone audio" string is translated properly in the test language.

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140929000203
Gaia: 063de64a4ffc606e931ed7b09e93282713c46eca
Gecko: 055d46b81ed1
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 100%
See attached: logcat, screenshot
(Reporter)

Comment 1

4 years ago
Created attachment 8497155 [details]
NotTranslated.png

This issue does NOT reproduce on Flame 2.0 and Flame 2.2:

Flame 2.0 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140929000203
Gaia: 5c2303ec4e367da060aa1b807d541a6549b3d72a
Gecko: 44f813760b88
Version: 32.0 (2.0)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame Master
Build ID: 20140929040202
Gaia: 2834baf4c7e34fe6ef335f0469f6d0f593c5922b
Gecko: 9d66436af432
Version: 35.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

The string "Connected to phone audio" is translated properly.
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

If this is a regression, we should block on this as this affects shipping locales
blocking-b2g: --- → 2.1?

Comment 3

4 years ago
Triage: regression, blocking. Assign to Ian now, thanks.
Assignee: nobody → iliu
blocking-b2g: 2.1? → 2.1+
QA Whiteboard: [QAnalyst-Triage?]
Keywords: regressionwindow-wanted
Axel,

this may be the same problem as bug 1074166, please help us check these strings on 2.1.

Thanks.
Flags: needinfo?(l10n)
Just have a check from our pvt/tbpl build(webapps/settings.gaiamobile.org/application/locales-obj/fr.json). 

Gaia-Rev        188eb969d8d0f246d85ef648f8981e700ac15b0a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/c20912812877
Build-ID        20140930171623
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140929.185314
FW-Date         Mon Sep 29 18:53:24 EDT 2014
Bootloader      L1TC10011800

Looks like the locales string is not translated in v2.1. It will need some help from l10n team. Leave assignee.
Assignee: iliu → nobody
Same answer of bug 1074166 comment 5
http://transvision.mozfr.org/string/?entity=apps/settings/device_type/phone/settings.device.properties:device-status-connected-device&repo=gaia

This should be a build issue not picking up device-specific strings.
French is fully localized on 2.1
Flags: needinfo?(l10n)
Chens, based on bug 1074166 comment 5, can you help to give it a check ? Thanks !!
Flags: needinfo?(shchen)
I think could be a duplicate of bug 1074166.
Flags: needinfo?(shchen)
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20140802202930
Gaia: 5fd14b8bc428f87f9b5cf9cc49f9a4f362a970fb
Gecko: e6614d8d85f9
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140804041427
Gaia: af9a0a24fb9f4c5ced3602bc14053bd49b136344
Gecko: 71497ed2e0db
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: 5fd14b8bc428f87f9b5cf9cc49f9a4f362a970fb
Gecko: 71497ed2e0db
Broken Gaia / Working Gecko = Repro
Gaia: af9a0a24fb9f4c5ced3602bc14053bd49b136344
Gecko: e6614d8d85f9
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/5fd14b8bc428f87f9b5cf9cc49f9a4f362a970fb...af9a0a24fb9f4c5ced3602bc14053bd49b136344


B2G Inbound
Last working
BuildID: 20140803122727
Gaia: c987645e91a87615e2faf3c0a76e114c0a5009b3
Gecko: 4a390946b5c9
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140803190227
Gaia: eae74908a7ab8493691b7fc6ec91d969821d9798
Gecko: 0c1dac455d45
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: c987645e91a87615e2faf3c0a76e114c0a5009b3
Gecko: 0c1dac455d45
Broken Gaia / Working Gecko = Repro
Gaia: eae74908a7ab8493691b7fc6ec91d969821d9798
Gecko: 4a390946b5c9
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/c987645e91a87615e2faf3c0a76e114c0a5009b3...eae74908a7ab8493691b7fc6ec91d969821d9798
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Broken by Bug 944604 - can you take a look Sherman?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(shchen)
Already working on bug 1074166, and I think these two are the same.
Flags: needinfo?(shchen)
Let's duplicate.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074166
removing blocking flag since this was resolved as a dupe
blocking-b2g: 2.1+ → ---
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.