Eager allocation of webrtc trace buffers was supposed to be turned off in Beta and Release

RESOLVED FIXED in Firefox 33, Firefox OS v2.1

Status

()

Core
WebRTC
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jesup, Assigned: jesup)

Tracking

({regression})

Other Branch
mozilla35
regression
Points:
---

Firefox Tracking Flags

(firefox32 wontfix, firefox33 fixed, firefox34 fixed, firefox35 fixed, b2g-v2.0 ?, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

(Whiteboard: [MemShrink:P2][webrtc-uplift])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
In Bug 970713 we said that lazy allocation of the ~8MB of webrtc trace buffers would need to be re-enabled for Beta and Release, and it wasn't.

This landed in 32, so 32 is the only release version to go out with it.

It's a single pref in gyp.mozbuild.

We need to check 2.0 as well.
(Assignee)

Comment 1

4 years ago
Created attachment 8497170 [details] [diff] [review]
lazy-allocate webrtc trace buffers in RELEASE_BUILDs
(Assignee)

Updated

4 years ago
Attachment #8497170 - Flags: review?(khuey)
Comment on attachment 8497170 [details] [diff] [review]
lazy-allocate webrtc trace buffers in RELEASE_BUILDs

Review of attachment 8497170 [details] [diff] [review]:
-----------------------------------------------------------------

I don't know if this is actually defined in this file, because I don't know how any of the gyp integration works. 302 ted.
Attachment #8497170 - Flags: review?(khuey) → review?(ted)
Attachment #8497170 - Flags: review?(ted) → review+
(Assignee)

Comment 3

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/e640b23767a5
Whiteboard: [memshrink] → [memshrink][webrtc-uplift]
(Assignee)

Comment 4

4 years ago
Comment on attachment 8497170 [details] [diff] [review]
lazy-allocate webrtc trace buffers in RELEASE_BUILDs

Approval Request Comment
[Feature/regressing bug #]: bug 970713

[User impact if declined]: 8MB memory use if webrtc or getusermedia is used

[Describe test coverage new/current, TBPL]: n/a (or if you prefer http://areweslimyet.com/ but it doesn't touch webrtc/gUM)

[Risks and why]: virtually none.  this was used in the past, and was supposed to be disabled on nightly and aurora only.

[String/UUID change made/needed]: none
Attachment #8497170 - Flags: approval-mozilla-beta?
Attachment #8497170 - Flags: approval-mozilla-aurora?
Whiteboard: [memshrink][webrtc-uplift] → [MemShrink:P2][webrtc-uplift]
https://hg.mozilla.org/mozilla-central/rev/e640b23767a5
Assignee: nobody → rjesup
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
status-firefox35: affected → fixed
Attachment #8497170 - Flags: approval-mozilla-beta?
Attachment #8497170 - Flags: approval-mozilla-beta+
Attachment #8497170 - Flags: approval-mozilla-aurora?
Attachment #8497170 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/8e8a24322b9a
https://hg.mozilla.org/releases/mozilla-beta/rev/002f9202019b
status-b2g-v2.1: ? → fixed
status-b2g-v2.2: ? → fixed
status-firefox33: affected → fixed
status-firefox34: affected → fixed
You need to log in before you can comment on or make changes to this bug.