Precondition: negative row in outliner GetCellAt() calc

RESOLVED FIXED

Status

()

RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: jesup, Assigned: janv)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When I try to turn off the "Total" column in mailnews, I get a "bad row"
assertion because aRow is -3.  This is due to:

#5  0x29c4953f in nsOutlinerBodyFrame::GetCellAt (this=0x9181214, aX=69, 
    aY=31, aRow=0xbfbf7fa0, aColID=0xbfbf7fb0, aChildElt=0xbfbf7fc0)
    at nsOutlinerBodyFrame.cpp:837

which calls AdjustEventCoordsToBoxCoordSpace ( aX, aY, &x, &y );, and this is
what we get for y:

(gdb) p *aRow
$3 = -3
(gdb) p y
$4 = -868
(gdb) p mRowHeight
$5 = 252
(gdb) p mInnerBox
$9 = {
  x = 0, 
  y = 0, 
  width = 2058, 
  height = 1470
}

This is quite repeatable.

Hyatt wrote this; pink factored out AdjustEvent....().

Comment 1

17 years ago
->varga
Assignee: hyatt → varga
(Assignee)

Comment 2

17 years ago
I think, I've already seen this. I'll look at it closely.
*** Bug 118597 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

17 years ago
fixed along with 116739
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.