If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Improve media recording test site

RESOLVED FIXED

Status

()

Core
Audio/Video: Recording
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: pyang, Assigned: atsai)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Currently testing on platform media recording/playback rely on http://people.mozilla.org/~rlin/MediaRecorder.html which created by Randy

It gives basic functionality, and we need slight fix to test on more materials.  Such like different ratio or other parameter for input stream. It does possible if we use file input stream, and we don't restrict user to do that.
(Assignee)

Comment 1

3 years ago
To clarify, QA was using http://mozilla.github.io/qa-testcase-data/webapi/mediarecorder/index.html for testing. Since QA are short of resource on maintaining, we'd like to know if it's possible to have it migrate to developers testing page.
The website provided by me(http://people.mozilla.org/~rlin/MediaRecorder.html)
was designed for internal development, I think it's not suitable for official testing. Developers may change the UI/test sample files or test step, that would affect the QA formal test case. Also increase the maintain effort on developers.
Hi Steven, could you get help from Randy for QA team? many thanks.
Assignee: nobody → slee
Flags: needinfo?(slee)
QA Contact: atsai
I had a copy of the test web site content on our file server and gave QA this information.
Flags: needinfo?(slee)
(Assignee)

Comment 5

3 years ago
Created attachment 8498712 [details] [review]
PR for new media recorder

Updated

3 years ago
Assignee: slee → atsai
paul, do we still need this?
Flags: needinfo?(pyang)
(Reporter)

Comment 7

2 years ago
looks like PR was merged already.
ni? Al for confirming.
Flags: needinfo?(pyang) → needinfo?(atsai)
(Assignee)

Comment 8

2 years ago
the patch is merged. close it as resolved fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(atsai)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.