If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XMLHttpRequest depends on the Profiles

VERIFIED WORKSFORME

Status

()

Core
DOM
VERIFIED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Jiri Znamenacek, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011026
BuildID:    2001102603

TransforMiiX (as part of Mozilla) handles XSLT transformation differently
depending on the user profile. It looks like with profile under "user50"
directory all transformations are broken, under "Profiles" directory everything
works right.

Reproducible: Always
Steps to Reproduce:
Try to open the appended testcase, either start.html or start.xml file.

Actual Results:  With old profile empty body tag is created.

Expected Results:  Complete form should be created (and is created with the new
profile).
(Reporter)

Comment 1

16 years ago
Created attachment 55661 [details]
zipped files of the testcase

Comment 2

16 years ago
could you try to verify that it's the transformation? Not the xml http request,
or any other step in that script?
Also, read the bug reporting guidelines on http://www.mozilla.org/projects/xslt
on how to submit multi file bugs. esp if we already stated that the test won't
run from file:// for some of us.
Please also try to move, or regenerate the appreg files, in the parent dir of
the profiles. This might be the root cause, though I don't know really why.
(Reporter)

Comment 3

16 years ago
Bingo! XMLHttpRequest is not working... (Wondering why I thought it had to be
TransforMiiX ;-) Changing component (hope to the right one) and reassigning to
Heikki. And appending slightly narrowed testcase.

BTW - should I file another bugs about badly rendered buttons and not working
JavaScript on them in generated XHTML fragment?
Assignee: kvisco → heikki
Component: XSLT → DOM Mozilla Extensions
Summary: TransforMiiX output depends on the Profiles → XMLHttpRequest depends on the Profiles
(Reporter)

Comment 4

16 years ago
Created attachment 55750 [details]
XML file to load
(Reporter)

Comment 5

16 years ago
Created attachment 55751 [details]
XSLT file to load
(Reporter)

Comment 6

16 years ago
Created attachment 55752 [details]
starting file of testcase (XHTML, contains JavaScript calls to the previous two attachments)
(Reporter)

Comment 7

16 years ago
Another comments:

Testcase directly from this page doesn't work for me. BUT with old profile it
complains "The requested URL could not be retrieved." and with the new one
"Software error - Couldn't get form data at CGI.pl line 1425." (And then it of
course segfault Mozilla when transformation is called - it's allreay reported as
#107219 .)

I also tried it from our intranet server. I had to change the POST method to GET
but otherwise the code stayed intact. Both XML and XSLT files are properly
loaded, but then Mozilla segfaults on transformation...

I'm afraid we need as much people as possible to test this ^_-
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 67518 [details]
Must do GET if send(null)
Using the latest Mozilla with the latest attachment this seems to work for me,
regardless of which profile I use (I have profiles under "Profiles" and
"Users50" directory).

If there is "user50" profile dir that was probably created with Netscape 6.0 or
a Mozilla before that. We have basically futured all problems related to that
profile.

Could you please retest and report...?
(Reporter)

Comment 10

16 years ago
Retest with 2002013003 and the last attachement - it works with both old (I hope
it's the one) and new profiles now. Should it be FIXED or WOKSFORME?

(BTW - Aren't there any bugs for "Save Page As..." with XSLT on the page? It's
saving the output of the transformation. I'm going to spam some newsgroups ^_^)
Marking wfm, thanks guys.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
QA Contact: keith → ian
reporter resolved
Status: RESOLVED → VERIFIED
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.