Firefox hangs on Samsung Galaxy Tab 4 with Flash installed

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Penticton, Unassigned)

Tracking

({crash, hang})

32 Branch
All
Android
crash, hang
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8497344 [details]
Screenshot_2014-09-30-01-07-19.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130406 Firefox/32.0.3
Build ID: 20140923174357

Steps to reproduce:

Viewing any and all websites, random intermittent but constant crashing/hanging.

I am using a Samsung Galaxy Tab 4 8.0Inch device, with the latest stable Firefox version, Android 4.4.2,  and my device Is rooted.


Actual results:

As some sites load I would attempt to view them but often FF would crash and or hang.

I did some troubleshooting and testing and narrowed the problem down to javascript.enabled, I set this to false and the problem completely disappears, but, who wants a browser that can't display anything on youtube.com? I have my useragent set to desktop mode only,  I go to youtube.com with the javascript.enabled set to false and the videos will not work, I want to be able to see and use youtube.com, but alas, if I set javascript.enabled to true, the crashing issues return.
What are my options here? Really do t want to use chrome or dolphin.
There has to be something I can do so i can use FF like the millions of other users who never have an issue.
Thankyou.


Expected results:

Sites should display and load normally without crashing.
(Reporter)

Updated

4 years ago
Severity: normal → major
Keywords: crash, hang
OS: Windows 7 → Android
Hardware: x86_64 → All
(Reporter)

Comment 1

4 years ago
I'm getting choked in a major way. Been f&%*ing with this for a few weeks now, someone pleasssssssssssse help me find a solution to this, I want to use FF, and no i don't want to DL a different browser.
You can try using Firefox Beta on Google Play to see if that resolves anything for you. Otherwise, if you see the crash reporter come up after a crash and are submitting a crash you can visit about:crashes in the browser and by providing me with the shown crash report ID I can determine wether this is fixed on a development branch.
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Settings and Preferences → General
Flags: needinfo?(Penticton)
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

4 years ago
Now using beta, and the problem persists, here is my catlog at the time this crash occurs.

10-03 18:46:46.574 D/CrashAnrDetector(816): Process: org.mozilla.firefox_beta
10-03 18:46:46.574 D/CrashAnrDetector(816): Flags: 0x88be44
10-03 18:46:46.574 D/CrashAnrDetector(816): Package: org.mozilla.firefox_beta v2014093005 (33.0)
10-03 18:46:46.574 D/CrashAnrDetector(816): Subject: Executing service org.mozilla.firefox_beta/org.mozilla.gecko.background.healthreport.prune.HealthReportPruneService
10-03 18:46:46.574 D/CrashAnrDetector(816): Build: samsung/milletwifiue/milletwifiue:4.4.2/KOT49H/T330NUUEU1AND4:user/release-keys
10-03 18:46:46.574 D/CrashAnrDetector(816): 
10-03 18:46:46.574 D/CrashAnrDetector(816): CPU usage from 8375ms to 0ms ago:
10-03 18:46:46.574 D/CrashAnrDetector(816):   22% 20036/com.nolanlawson.logcat: 21% user + 1.1% kernel / faults: 248 minor
10-03 18:46:46.574 D/CrashAnrDetector(816):   1.6% 816/system_server: 0.4% user + 1.1% kernel / faults: 10 minor
10-03 18:46:46.574 D/CrashAnrDetector(816):   1% 246/surfaceflinger: 0.4% user + 0.5% kernel / faults: 4 minor
10-03 18:46:46.574 D/CrashAnrDetector(816):   1% 1941/mpdecision: 0.2% user + 0.8% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.5% 549/kworker/u:2H: 0% user + 0.5% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.5% 24219/kworker/u:1: 0% user + 0.5% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.4% 2686/kworker/u:3: 0% user + 0.4% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.2% 3/ksoftirqd/0: 0% user + 0.2% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.2% 1034/com.android.systemui: 0.1% user + 0.1% kernel / faults: 5 minor
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.2% 2860/com.ea.games.simsfreeplay_row:remote: 0.2% user + 0% kernel / faults: 27 minor
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.2% 3479/com.cleanmaster.mguard:service: 0.2% user + 0% kernel / faults: 3 minor
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.2% 4947/kworker/0:2H: 0% user + 0.2% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 1//init: 0% user + 0.1% kernel / faults: 18 minor
10-03 18:46:46.574 D/CrashAnrDetector(816):   0% 2/kthreadd: 0% user + 0% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 7/kworker/u:0H: 0% user + 0.1% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0% 234/edmaudit: 0% user + 0% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0% 266/qrngd: 0% user + 0% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 533/mdss_fb0: 0% user + 0.1% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 1010/wpa_supplicant: 0% user + 0.1% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0% 1740/org.mozilla.firefox_beta: 0% user + 0% kernel / faults: 9 minor
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 3441/com.google.android.apps.maps: 0% user + 0.1% kernel / faults: 20 minor
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 4598/su: 0% user + 0.1% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 4604/logcat: 0% user + 0.1% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 20069/daemonsu:10096: 0% user + 0.1% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 24790/kworker/0:0H: 0% user + 0.1% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 25972/su: 0% user + 0.1% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816):   0.1% 25976/daemonsu:10246: 0% user + 0.1% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816): 24% TOTAL: 19% user + 5% kernel
10-03 18:46:46.574 D/CrashAnrDetector(816): 
10-03 18:46:46.574 D/CrashAnrDetector(816): 
10-03 18:46:46.574 D/CrashAnrDetector(816): processName: org.mozilla.firefox_beta
10-03 18:46:46.574 D/CrashAnrDetector(816): broadcastEvent : org.mozilla.firefox_beta data_app_anr
10-03 18:46:46.574 W/ContextImpl(816): Calling a method in the system process without a qualified user: android.app.ContextImpl.sendBroadcast:1523 com.android.server.analytics.data.collection.application.CrashAnrDetector.broadcastEvent:296 com.android.server.analytics.data.collection.application.CrashAnrDetector.processDropBoxEntry:254 com.android.server.analytics.data.collection.application.CrashAnrDetector.access$100:60 com.android.server.analytics.data.collection.application.CrashAnrDetector$1.onReceive:102
Flags: needinfo?(Penticton)
(Reporter)

Comment 4

4 years ago
Created attachment 8499947 [details]
2014-10-03-18-46-58.txt

Here is the FULL log from catlog during the time this crash occurs, the excerpt pasted in the body of one of my replies is just showing the crashanr filter results.
Comment on attachment 8499947 [details]
2014-10-03-18-46-58.txt

10-03 18:46:29.444 D/GeckoAppShell(1740): Gecko event sync taking too long: 100813ms

Any thoughts, chaps?
Flags: needinfo?(bugmail.mozilla)
Flags: needinfo?(blassey.bugs)
Penticton: do you have any add-ons installed?
Flags: needinfo?(Penticton)
(Reporter)

Comment 7

4 years ago
(In reply to Richard Newman [:rnewman] from comment #6)
> Penticton: do you have any add-ons installed?


Nope, no addons installed.
Flags: needinfo?(Penticton)
Smells like a deadlock somewhere. Can we get the /data/anr/traces.txt file? Also, shouldn't the hang reporter have kicked in on this?
Flags: needinfo?(bugmail.mozilla)
(Reporter)

Comment 9

4 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #8)
> Smells like a deadlock somewhere. Can we get the /data/anr/traces.txt file?
> Also, shouldn't the hang reporter have kicked in on this?

I have added the traces.txt file.
(Reporter)

Comment 10

4 years ago
Created attachment 8500057 [details]
traces.txt

Traces.exe for crash timeframe.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #8)
> Smells like a deadlock somewhere. Can we get the /data/anr/traces.txt file?
> Also, shouldn't the hang reporter have kicked in on this?

We are only collecting hang reports for Nightly and Aurora.

(In reply to Penticton from comment #10)
> Created attachment 8500057 [details]
> traces.txt
> 
> Traces.exe for crash timeframe.

Thank you, Penticton! Seems like Flash Player is causing the hang. Do you know which version of Flash Player you have? Maybe you can try installing a different version and see if that fixes it?
(Reporter)

Comment 12

4 years ago
(In reply to Jim Chen [:jchen :nchen] from comment #11)
> (In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #8)
> > Smells like a deadlock somewhere. Can we get the /data/anr/traces.txt file?
> > Also, shouldn't the hang reporter have kicked in on this?
> 
> We are only collecting hang reports for Nightly and Aurora.
> 
> (In reply to Penticton from comment #10)
> > Created attachment 8500057 [details]
> > traces.txt
> > 
> > Traces.exe for crash timeframe.
> 
> Thank you, Penticton! Seems like Flash Player is causing the hang. Do you
> know which version of Flash Player you have? Maybe you can try installing a
> different version and see if that fixes it?


I am using Flash Player 11.1 for Android 4.0 (11.1.115.81), I was told flash was no longer supported
for android devices, but I saw a website that said I could install an archived version and it should work just fine with my device.
Do you have any suggestions as to how I can get a stable working version of flash with firefox?

I will try an older version of it as you said, I'll post results back here. ..
(Reporter)

Comment 13

4 years ago
I uninstalled Flash Player 11.1 for Android 4.0 (11.1.115.81) from my device, and oddly enough firefox still plays flash content on youtube.com even without it installed, Firefox comes with flash? 
Also, I am unable to replicate the problem since removing it.
So I guess my issue is resolved?

I'm stumped as to why I'm still able to view flash content in firefox even though I installed it.
If firefox has its own way to render flash content, my hypothesis is that maybe the two versions were conflicting with each other in some way?

Stumped...... lol
If I had to guess, I'd say that YouTube is now serving you HTML5 video, which will play just fine.

Adobe stopped supporting Flash a long time ago.
Flags: needinfo?(blassey.bugs)
Resolution: INCOMPLETE → WORKSFORME
Summary: FF hangs unless javascript.enabled set to false. → Firefox hangs on Samsung Galaxy Tab 4 with Flash installed
Without Flash, YouTube plays HTML5 video; that is if you don't have YouTube installed or enabled on your device (typically the browser will open the native YouTube application)
(Reporter)

Comment 16

4 years ago
(In reply to Richard Newman [:rnewman] from comment #14)
> If I had to guess, I'd say that YouTube is now serving you HTML5 video,
> which will play just fine.
> 
> Adobe stopped supporting Flash a long time ago.

Ahhh yes, it is showing html5 now, but how can I insure other sites will display flash content?

You see, I have an android device, I have my useragent set to only show me desktop versions, I do have the youtube app installed,  but prefer to use the browser to access youtube as you can't make video comments from the app, only the website itself. ..

Not sure what to do from here, what do you guys do on your Android devices when it comes to flash?
(Reporter)

Comment 17

4 years ago
(In reply to Aaron Train [:aaronmt] from comment #15)
> Without Flash, YouTube plays HTML5 video; that is if you don't have YouTube
> installed or enabled on your device (typically the browser will open the
> native YouTube application)

I have my device set to show desktop versions of sites only, this negates the use of the youtube app, how should I have my device set up? The ua to show desktop sites? Put it back to default and leave it alone? Not sure what the best way is, what do you do with your devices?
(In reply to Penticton from comment #17)
> Not sure what the best way is, what do you do with your devices?

I haven't needed to browse routinely with a desktop UA since about 2012. I use "Request desktop site" from the menu maybe once or twice a month.

I use the YouTube app quite often, because it has a more flexible full-screen and better integration with their Favorites and Watch Later lists.

You *can* use the YouTube app to leave comments: see this screenshot.

https://dl.dropboxusercontent.com/u/3911373/Fennec/Screenshot_2014-10-04-20-03-26.png


I don't miss Flash at all.
(Reporter)

Comment 19

4 years ago
Thankyou to everyone who commented and helped, all of you helped me to narrow down the problem, if flash isn't supported then there's bound to be issues I'd reckon.

Everything is great now, Firefox is working fine, and I got rid of the desktop useragent string, there's really no need for it.

And Richard, thanks, I see the comments area now on the youtube app, for some reason I overlooked this.


All good, thanks again everyone.
Signed, Faithful Firefox user.
You need to log in before you can comment on or make changes to this bug.