Closed Bug 1074790 Opened 5 years ago Closed 5 years ago

[Messages] We should revoke contact image blob URL when contact or its image is removed

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S6 (10oct)
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: azasypkin, Assigned: azasypkin)

Details

(Whiteboard: [sms-sprint-2.1S6])

Attachments

(1 file)

While working on bug 1003843, we've noticed that we revoke contact image blob URLs only when thread is removed, but don't do it when thread contact or its image is removed.
Looks like it's more serious and broader issue since we generate new blob URL for every thread contact with image on "contanctchange" event, but don't revoke the old one.
Hey Julien,

Here is the small patch that should fix this issue.

Thanks!
Attachment #8497479 - Flags: review?(felash)
Comment on attachment 8497479 [details] [review]
GitHub pull request URL

let's land this and request approval on 2.1 :)
Attachment #8497479 - Flags: review?(felash) → review+
(In reply to Julien Wajsberg [:julienw] from comment #3)
> Comment on attachment 8497479 [details] [review]
> GitHub pull request URL
> 
> let's land this and request approval on 2.1 :)

Thanks for review!

Master: https://github.com/mozilla-b2g/gaia/commit/a32c138c9f7e30a7f79d4c16fe18f80f05c07124
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8497479 [details] [review]
GitHub pull request URL

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): n/a
[User impact] if declined: memory leaks in SMS app when user adds\removes\updates contacts, can be significant if user has a lot of message threads with contact images
[Testing completed]: yes, unit tests
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: n/a
Attachment #8497479 - Flags: approval-gaia-v2.1?
Attachment #8497479 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
You need to log in before you can comment on or make changes to this bug.