2.53 Linux32 Dromaeo CSS regression on inbound (v.35) Sept 26 from push 61e654fd0637

RESOLVED FIXED

Status

()

Core
JavaScript Engine: JIT
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

({perf, regression})

33 Branch
x86
Linux
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression])

Yes there was an email send. But this is just a bug in a patch that caused an improvement, which went away when fixed.

September 23
> Improvement: Mozilla-Inbound-Non-PGO - Dromaeo (CSS) - Ubuntu HW 12.04 x64 - 2.59% increase
> -------------------------------------------------------------------------------------------
>     Previous: avg 5337.143 stddev 46.026 of 12 runs up to revision b3c0b2156cff
>     New     : avg 5475.374 stddev 48.344 of 12 runs since revision 6465e8acae5e
>     Change  : +138.231 (2.59% / z=3.003)
>     Graph   : http://mzl.la/1rtvxsZ
> 
> Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b3c0b2156cff&tochange=6465e8acae5e
> 
> Changesets:
>   * http://hg.mozilla.org/integration/mozilla-inbound/rev/6465e8acae5e
>     : Hannes Verschore <hv1989@gmail.com> - Bug 1064537: IonMonkey: Try folding ternary constructs, r=nbp
>     : http://bugzilla.mozilla.org/show_bug.cgi?id=1064537
> 
> Bugs:
>   * http://bugzilla.mozilla.org/show_bug.cgi?id=1064537 - Fold a ? a : 0 for number types

September 29
> Regression: Mozilla-Inbound-Non-PGO - Dromaeo (CSS) - Ubuntu HW 12.04 - 2.53% decrease
> --------------------------------------------------------------------------------------
>     Previous: avg 4909.647 stddev 38.480 of 12 runs up to revision ad7022a0b953
>     New     : avg 4785.508 stddev 34.994 of 12 runs since revision 61e654fd0637
>     Change  : -124.138 (2.53% / z=3.226)
>     Graph   : http://mzl.la/1oreYcj
> 
> Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ad7022a0b953&tochange=61e654fd0637
> 
> Changesets:
>   * http://hg.mozilla.org/integration/mozilla-inbound/rev/2bac3aaede24
>     : Hannes Verschore <hv1989@gmail.com> - Bug 1072691: IonMonkey: Fix hoisting of operand when folding ternary structure, r=nbp
>     : http://bugzilla.mozilla.org/show_bug.cgi?id=1072691
> 
>   * http://hg.mozilla.org/integration/mozilla-inbound/rev/61e654fd0637
>     : Hannes Verschore <hv1989@gmail.com> - Bug 1072691: IonMonkey: Fix case of negative zero when folding ternary structure, r=nbp
>     : http://bugzilla.mozilla.org/show_bug.cgi?id=1072691
> 
> Bugs:
>   * http://bugzilla.mozilla.org/show_bug.cgi?id=1072691 - Crash [@ js::jit::LiveInterval::addRangeAtHead] or Assertion failure: opIter != block->end() (Operand in same block as instruction does not precede), or Assertion failure: opBlock->dominates(*block) (Instruction is not dominated by its operands),
(Reporter)

Comment 2

3 years ago
got it, thanks for clarifying :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.