Closed Bug 1074903 Opened 5 years ago Closed 5 years ago

[Browser Start Page] No title shown for top site

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
2.1 S6 (10oct)

People

(Reporter: epang, Assigned: daleharvey)

Details

(Keywords: polish, Whiteboard: [systemsfe])

Attachments

(2 files)

Attached image 2014-09-30-17-04-12.png
The black banner and title is not always shown for all screens.
In the attached example it's missing from the first screen.
Hey Dale, I'm guessing this is because a title in not available?  I think in this case we should show a url, looks odd with nothing there.  Francis, what do you think?
Flags: needinfo?(fdjabri)
Flags: needinfo?(dale)
Its feasible that we dont have a title, I thought it was covered but will check and fix if not
Flags: needinfo?(dale)
QA Contact: dale
(In reply to Eric Pang [:epang] from comment #1)
> Hey Dale, I'm guessing this is because a title in not available?  I think in
> this case we should show a url, looks odd with nothing there.  Francis, what
> do you think?

Agreed, that sounds like a good idea.
Flags: needinfo?(fdjabri)
Dale - I assumed that you wanted to assign this to yourself instead of being the qa contact? :)
Assignee: nobody → dale
QA Contact: dale
Heh cheers for fixing assignment, based this on top of https://bugzilla.mozilla.org/show_bug.cgi?id=1071057 as I needed it for testing
Attachment #8498387 - Flags: review?(kgrandon)
Comment on attachment 8498387 [details]
https://github.com/daleharvey/gaia/commit/f8a08ea9541df4b15aeda7282352174c97b00ec4

Thanks for the test. I left one comment on github.
Attachment #8498387 - Flags: review?(kgrandon) → review+
Switched the test to an async, cheers

https://github.com/mozilla-b2g/gaia/commit/d711d1e469eeeecf25a02b2407a542a598918b2c
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S6 (10oct)
You need to log in before you can comment on or make changes to this bug.