bugzilla cc autocomplete is too aggressive

RESOLVED INVALID

Status

()

Bugzilla
User Interface
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: andy, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140918134209

Steps to reproduce:

I went to this bug report:

https://bugzilla.mozilla.org/show_bug.cgi?id=1073224

I clicked the "Add" box in the "CC List".  I typed "hawksley@gmail.com".  I did *not* accept any autocompletes.  I clicked "Save Changes".


Actual results:

john.hawksley@gmail.com was CCed.


Expected results:

Either hawksley@gmail.com should have been CCed or I should have received an error.

To double-check the UI is indeed broken, I tried again very carefully.  I typed "hawksley@gmail.com" and I clicked outside dropdown to dismiss it.  Then I saved changes again.  No dice: it still thought I wanted to CC john.hawksley.

Then I typed an actual name followed by "(hawksley@gmail.com)" and tried to save.  That finally resulted in an error (specifically that hawksley@gmail.com is not known to Bugzilla).

All three of my attempts should have resulted in that error, and john.hawksley@gmail.com should not have been CCed.
(Reporter)

Updated

4 years ago
Summary: bugzilla cc autocomplete → bugzilla cc autocomplete is too aggressive
Re-categorizing closer to the folks who can do something about this
Assignee: nobody → general
Component: General → Bugzilla-General
Product: Mozilla Services → Bugzilla
QA Contact: default-qa

Comment 2

4 years ago
Autocompletion is great, and typing partial email addresses is very common. If admins don't like that, then they can enable the confirmuniqueusermatch parameter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

4 years ago
I'm fine with typing partial email addresses, if those partial addresses are prefixes of the full address (this wasn't) and if *clicking outside the autocomplete box to dismiss it* didn't silently autocomplete anyway.

Look at Firefox's in-browser autocomplete for an example of a perfectly fine autocomplete mechanism.

Comment 4

4 years ago
I agree.  I don't consider it autocomplete if it doesn't update the actual input box but silently decides to use it--that's autoguess.  You should have to explicitly choose the suggestion.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---

Updated

4 years ago
Assignee: general → ui
Component: Bugzilla-General → User Interface

Comment 5

4 years ago
(In reply to Mark Côté [:mcote] from comment #4)
> You should have to explicitly choose the suggestion.

As I said in comment 2, there is a parameter for that. On BMO, this param is off. No need for extra code.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID

Comment 6

4 years ago
Ah true, it's enabled on the local BMO dev box, but not on BMO.  dkl, is there some particular reason it's disabled on BMO?
Status: RESOLVED → REOPENED
Flags: needinfo?(dkl)
Resolution: INVALID → ---

Comment 7

4 years ago
Sorry, didn't mean to reopen that.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID
Wouldn't turning it on break being able to CC mcote by entering ":mcote" and pressing enter? I don't think that's a good idea.

Comment 9

4 years ago
Yeah it would.  (Well, it would take you to a confirmation screen, requiring another click).  I didn't realize people actually did that. :) I don't think we can have it both ways, then...
(Reporter)

Comment 10

4 years ago
Sounds like there should be an intermediate option in which pressing enter selects the top autocomplete suggestion and in which there's no prompt in the contents of the text box actually match a full email address.
(In reply to Mark Côté [:mcote] from comment #6)
> Ah true, it's enabled on the local BMO dev box, but not on BMO.  dkl, is
> there some particular reason it's disabled on BMO?

No reason that I am aware of. I have not twiddled that from what I can remember since joining. It is probably 'on' on the BMO test box as that is the default value and we create the test box with all default settings (maybe we should change that).

dlkl
Flags: needinfo?(dkl)
You need to log in before you can comment on or make changes to this bug.