Closed Bug 1075011 Opened 6 years ago Closed 5 years ago

[TCP][Flatfish][Homescreen] No icons on homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, blocker)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(b2g-v2.1 fixed, b2g-v2.2 fixed)

VERIFIED FIXED
2.1 S6 (10oct)
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: rillian, Assigned: benfrancis)

References

Details

(Whiteboard: [Flatfish][TCP][systemsfe])

Attachments

(1 file)

Today's b2g master (2.2) on flatfish shows no icons on the homescreen at all. Apps can be launched through the WebIDE. gaia commit a32c138c9f7e30a7f79d4c16fe18f80f05c07124

`adb logcat` says:

W/Homescreen( 1755): [JavaScript Error: "TypeError: pages[currentPage] is undefined" {file: "app://homescreen.gaiamobile.org/js/grid.js" line: 263}]
W/Homescreen( 1755): [JavaScript Error: "TypeError: pageHelper.getCurrent(...) is undefined" {file: "app://homescreen.gaiamobile.org/js/grid.js" line: 224}]
Blocks: 1018655
Summary: [TCP][Homescreen] No icons on homescreen → [TCP][Flatfish][Homescreen] No icons on homescreen
Whiteboard: [Flatfish][TCP]
# good: [055c380b17ae0b7e18f4886d3988eca96d6c2048] Merge pull request #24061 from etiennesegonzac/bug-1043870-homescreen-integration-back
git bisect good 055c380b17ae0b7e18f4886d3988eca96d6c2048
# bad: [a32c138c9f7e30a7f79d4c16fe18f80f05c07124] Merge pull request #24563 from azasypkin/bug-1074790-revoke-blob-url
git bisect bad a32c138c9f7e30a7f79d4c16fe18f80f05c07124
# good: [51cb022edbe97725c42477be1900de2cf4f43ae2] Bug 1062803 - Replace the custom functions used to load JSON files with the new shared helper in the system app.
git bisect good 51cb022edbe97725c42477be1900de2cf4f43ae2
# good: [2de378df37b6cfee2033095ea40922264a8559e7] Bug 1069992 - [E-Mail] Wobbly Refresh Icon Animation
git bisect good 2de378df37b6cfee2033095ea40922264a8559e7
# bad: [ec1b3b90248b5649aa5ab64cef171d3101f2834b] Merge pull request #24537 from mnjul/bug_1074095_highlite_last_alt_key_at_container_area
git bisect bad ec1b3b90248b5649aa5ab64cef171d3101f2834b
# bad: [e96f8dd7e881693e80b93371d76d2178db6c15c5] Merge pull request #24421 from RickyChien/bug-1041463
git bisect bad e96f8dd7e881693e80b93371d76d2178db6c15c5
# bad: [d3c2612b3b4884b14f4cb421ea60f2925c8e37dd] Merge pull request #24357 from malini/kickoff
git bisect bad d3c2612b3b4884b14f4cb421ea60f2925c8e37dd
# bad: [58e3bdf9b7a7776451f74ad3bfe7af5ad58dffca] Bug 1043959 - Remove the browser app
git bisect bad 58e3bdf9b7a7776451f74ad3bfe7af5ad58dffca
# good: [830cbc8c79d145150c6e4b16cdc147261a49fe83] Merge pull request #24519 from gaye/test-test-agent-upgrade
git bisect good 830cbc8c79d145150c6e4b16cdc147261a49fe83
# first bad commit: [58e3bdf9b7a7776451f74ad3bfe7af5ad58dffca] Bug 1043959 - Remove the browser app
Severity: normal → major
blocking the release of Flatfish Device build. So need to be a blocker bug.
Severity: major → blocker
blocking-b2g: --- → 2.2?
I have not experienced this bug after flashing 20141006 (gaia f00b5919) from 20140930 build without flash userdata, have a normal homescreen on Flatfish.
I'm also experiencing this as of today (Oct-08-2014), with the source pulled just now from the repos and a freshly flashed image.
I can reproduce this, I haven't figured out what's causing it yet though...
Found it. The old homescreen referenced the browser app in its configuration and when it couldn't find the browser app it fell over. Switched it out for the search app and I'm un-hiding the search app at the same time to fix bug 1059697.
Attachment #8502010 - Flags: review?(kgrandon)
Assignee: nobody → bfrancis
Comment on attachment 8502010 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/24958

Seems like this should work. Let's make sure gaia-try is green before landing. Thanks!
Attachment #8502010 - Flags: review?(kgrandon) → review+
Thanks Kevin, Treeherder is green.

https://github.com/mozilla-b2g/gaia/commit/01164468f072760d6852d379644a2535ea1428be

Does flatfish care about 2.1? This is probably broken there too since the uplift.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Flatfish][TCP] → [Flatfish][TCP][systemsfe]
Target Milestone: --- → 2.1 S6 (10oct)
Thanks a lot Ben for fixing it. marking as "verifyme" to check if its fixed in the latest build of Flatfish
Keywords: verifyme
Duplicate of this bug: 1059697
Awesome, thanks guys! Just did a build and flashed the image - working perfectly.
It works perfectly in the latest build. Thanks a lot ben
Status: RESOLVED → VERIFIED
blocking-b2g: 2.2? → ---
Keywords: verifyme
Ben, can you please uplift and merge it in 2.1 also?
Flags: needinfo?(bfrancis)
Comment on attachment 8502010 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/24958

We can ask, but I don't know whether a flatfish bug will be allowed to land on 2.1 post-FC.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1043959
[User impact] if declined: No icons on flatfish homescreen, device unusable
[Testing completed]: Manual
[Risk to taking this patch] (and alternatives if risky): This two line change only effects the old homescreen app which doesn't ship on smartphone devices, but is used by tablets.
[String changes made]: None.
Attachment #8502010 - Flags: approval-gaia-v2.1?
Flags: needinfo?(bfrancis)
Attachment #8502010 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
You need to log in before you can comment on or make changes to this bug.